FreeBSD: webkit-gtk -- 複数の脆弱性(e3aacd6d-3d01-434c-9330-bc9efd40350f)

high Nessus プラグイン ID 122413

言語:

概要

リモートのFreeBSDホストに1つ以上のセキュリティ関連の更新プログラムがありません。

説明

Webkitgtkプロジェクトによる報告:

CVE-2019-6212 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、複数のメモリ破損の問題に対処しました。

CVE-2019-6215 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。型の取り違え(Type Confusion)の問題は、メモリ処理を改善することで対処しました。

CVE-2019-6216 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、複数のメモリ破損の問題に対処しました。

CVE-2019-6217 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、複数のメモリ破損の問題に対処しました。

CVE-2019-6226 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、複数のメモリ破損の問題に対処しました。

CVE-2019-6227 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、メモリ破損の問題に対処しました。

CVE-2019-6229 - 悪意のある細工されたWebコンテンツを処理すると、ユニバーサルクロスサイトスクリプティングが引き起こされる可能性があります。ロジックの問題は、検証の改善により対処しました。

CVE-2019-6233 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、メモリ破損の問題に対処しました。

CVE-2019-6234 - 悪意のある細工をしたWebコンテンツを処理すると、任意のコードが実行される可能性があります。メモリ処理の改善により、メモリ破損の問題に対処しました。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://webkitgtk.org/security/WSA-2019-0001.html

http://www.nessus.org/u?d9ed359d

プラグインの詳細

深刻度: High

ID: 122413

ファイル名: freebsd_pkg_e3aacd6d3d01434c9330bc9efd40350f.nasl

バージョン: 1.3

タイプ: local

公開日: 2019/2/25

更新日: 2019/4/2

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:freebsd:freebsd:webkit-gtk2, p-cpe:/a:freebsd:freebsd:webkit-gtk3, p-cpe:/a:freebsd:freebsd:webkit2-gtk3, cpe:/o:freebsd:freebsd

必要な KB アイテム: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/2/24

脆弱性公開日: 2019/2/8

参照情報

CVE: CVE-2019-6212, CVE-2019-6215, CVE-2019-6216, CVE-2019-6217, CVE-2019-6226, CVE-2019-6227, CVE-2019-6229, CVE-2019-6233, CVE-2019-6234