SUSE SLED12 / SLES12セキュリティ更新プログラム:python(SUSE-SU-2019:0482-1)

high Nessus プラグイン ID 122446

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

python用のこの更新は、次の問題を修正します:

修正されたセキュリティ問題:

CVE-2019-5010:X509証明書解析ツールに存在するサービス拒否の脆弱性を修正しました(bsc#1122191)。

CVE-2018-14647:Expatのサービス拒否の脆弱性を修正しました(bsc#1109847)。

修正された非セキュリティ問題:PyWeakReference構造体が正しく初期化されず、クラッシュを引き起こすバグを修正しました(bsc#1073748)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE OpenStack Cloud 7:zypper in -t patch SUSE-OpenStack-Cloud-7-2019-482=1

SUSE Linux Enterpriseワークステーション拡張12-SP4:zypper in -t patch SUSE-SLE-WE-12-SP4-2019-482=1

SUSE Linux Enterprise Workstation Extension 12-SP3:zypper in -t patch SUSE-SLE-WE-12-SP3-2019-482=1

SUSE Linux Enterprise Software Development Kit 12-SP4:zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-482=1

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-482=1

SUSE Linux Enterprise Server for SAP 12-SP2:zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-482=1

SUSE Linux Enterprise Server 12-SP4:zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-482=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-482=1

SUSE Linux Enterprise Server 12-SP2-LTSS:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2019-482=1

SUSE Linux Enterprise Server 12-SP2-BCL:zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2019-482=1

SUSE Linux Enterprise Server 12-SP1-LTSS:zypper in -t patch SUSE-SLE-SERVER-12-SP1-2019-482=1

SUSE Linux Enterprise Desktop 12-SP4:zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-482=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2019-482=1

SUSE Enterprise Storage 5:zypper in -t patch SUSE-Storage-5-2019-482=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2019-482=1

SUSE CaaS Platform ALL:

この更新プログラムをインストールするには、SUSE CaaS Platform Velumダッシュボードを使用してください。新しい更新を検出した場合は通知され、その後、制御された方法でクラスター全体の更新をトリガーできます。

SUSE CaaS Platform 3.0:

この更新プログラムをインストールするには、SUSE CaaS Platform Velumダッシュボードを使用してください。新しい更新を検出した場合は通知され、その後、制御された方法でクラスター全体の更新をトリガーできます。

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-482=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1073748

https://bugzilla.suse.com/show_bug.cgi?id=1109847

https://bugzilla.suse.com/show_bug.cgi?id=1122191

https://www.suse.com/security/cve/CVE-2018-14647/

https://www.suse.com/security/cve/CVE-2019-5010/

http://www.nessus.org/u?2d7e1e60

プラグインの詳細

深刻度: High

ID: 122446

ファイル名: suse_SU-2019-0482-1.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/2/26

更新日: 2021/1/13

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libpython2_7, p-cpe:/a:novell:suse_linux:libpython2_7-1_0, p-cpe:/a:novell:suse_linux:libpython2_7-1_0-debuginfo, p-cpe:/a:novell:suse_linux:python, p-cpe:/a:novell:suse_linux:python-base, p-cpe:/a:novell:suse_linux:python-base-debuginfo, p-cpe:/a:novell:suse_linux:python-base-debugsource, p-cpe:/a:novell:suse_linux:python-curses, p-cpe:/a:novell:suse_linux:python-curses-debuginfo, p-cpe:/a:novell:suse_linux:python-debuginfo, p-cpe:/a:novell:suse_linux:python-debugsource, p-cpe:/a:novell:suse_linux:python-demo, p-cpe:/a:novell:suse_linux:python-devel, p-cpe:/a:novell:suse_linux:python-gdbm, p-cpe:/a:novell:suse_linux:python-gdbm-debuginfo, p-cpe:/a:novell:suse_linux:python-idle, p-cpe:/a:novell:suse_linux:python-tk, p-cpe:/a:novell:suse_linux:python-tk-debuginfo, p-cpe:/a:novell:suse_linux:python-xml, p-cpe:/a:novell:suse_linux:python-xml-debuginfo, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/2/25

脆弱性公開日: 2018/9/25

参照情報

CVE: CVE-2018-14647, CVE-2019-5010