PHP 7.0.x < 7.0.0の複数の脆弱性

high Nessus プラグイン ID 122536
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストにインストールされているアプリケーションは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.0.0より前の7.xです。したがって、次の脆弱性の影響を受けます。- ext/zip/php_zip.cスクリプトのZipArchive::extractTo関数にあるディレクトリトラバーサルの脆弱性。認証されていないリモートの攻撃者がこれを悪用し、空のディレクトリを持つ細工されたZIPアーカイブを送信して、サーバーの制限されたパスの外側にあるファイルの内容を漏えいさせる可能性があります。(CVE-2014-9767)- openssl.cファイルのopenssl_random_pseudo_bytes()関数が十分な乱数を生成しません。これによって、攻撃者が簡単に結果を予測でき、そのために、さらに攻撃が行われる可能性があります。(CVE-2015-8867)- 過剰に大きい負の座標を持つ細工された画像を処理するとき、gd.cファイル内のgdImageFillToBorder()関数のGDグラフィックライブラリにサービス拒否の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、細工された画像を通じて、ライブラリにリンクしているプロセスをクラッシュさせる可能性があります。(CVE-2015-8874)- SQL_WVARCHAR列に対するドライバーの動作が誤っているため、ext/odbc/php_odbc.cスクリプトのodbc_bindcols関数にサービス拒否(DoS)の脆弱性があります。認証されていないリモートの攻撃者がこの問題を悪用し、odbc_fetch_array関数を介して、アプリケーションの応答を停止させる可能性があります。(CVE-2015-8879)Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PHPバージョン7.0.0以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.0

プラグインの詳細

深刻度: High

ID: 122536

ファイル名: php_7_0_0.nasl

バージョン: 1.2

タイプ: remote

ファミリー: CGI abuses

公開日: 2019/3/1

更新日: 2019/10/31

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2015-8867

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/12/3

脆弱性公開日: 2015/12/3

参照情報

CVE: CVE-2014-9767, CVE-2015-8867, CVE-2015-8874, CVE-2015-8879

BID: 76652, 87481, 90714, 90842