PHP 7.0.x < 7.0.33の複数の脆弱性

high Nessus プラグイン ID 122821
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.0.33より前の7.0.xです。したがって、複数の脆弱性の影響を受けます:- メールボックス名をrshまたはsshコマンドに渡す前に不適切なフィルターを適用するため、任意のコマンド挿入の脆弱性がimap_open関数にあります。認証されたリモートの攻撃者がこれを悪用し、特別に細工したIMAPサーバー名を送信して、標的のシステム上で任意のコマンドを実行する可能性があります。(CVE-2018-19518)- phar_parse_pharfile関数にヒープベースのバッファオーバーリードがあります。認証されていないリモートの攻撃者がこれを悪用して、.pharファイルを解析しようとしたときに実際のデータを超えて割り当て済みまたは未割り当てのメモリを読み取る可能性があります。(CVE-2018-20783)

ソリューション

PHPバージョン7.0.33以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.33

プラグインの詳細

深刻度: High

ID: 122821

ファイル名: php_7_0_33.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2019/3/13

更新日: 2019/10/30

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2018-19518

VPR

リスクファクター: High

スコア: 8.4

CVSS v2

リスクファクター: High

Base Score: 8.5

Temporal Score: 7

ベクトル: AV:N/AC:M/Au:S/C:C/I:C/A:C

現状ベクトル: E:F/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 7

ベクトル: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/12/6

脆弱性公開日: 2018/11/14

エクスプロイト可能

Metasploit (php imap_open Remote Code Execution)

参照情報

CVE: CVE-2018-19518, CVE-2018-20783

BID: 106018, 107121