openSUSEセキュリティ更新プログラム:tiff(openSUSE-2019-847)

high Nessus プラグイン ID 123354

言語:

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

tiff 用のこの更新は、次の問題を修正します:

修正されたセキュリティ問題:

- CVE-2018-10779:tif_write.cのTIFFWriteScanlineに、ヒープベースのバッファオーバーリードがありました。これはbmp2tiffで実証されています。(bsc#1092480)

- CVE-2018-17100:tools/ppm2tiff.cのmultiply_msのint32オーバーフローにより、細工されたイメージファイルを介して、サービス拒否(クラッシュ)を引き起こしたり、詳細不明なその他の影響を及ぼしたりする可能性があります。(bsc#1108637)

- CVE-2018-17101:tools/tiff2bw.cおよびtools/pal2rgb.cのcpTagsに2つの境界外書き込みがあります。これは、細工されたイメージファイルを介して、サービス拒否(アプリケーションクラッシュ)を引き起こしたり、詳細不明なその他の影響を及ぼしたりする可能性があります(bsc#1108627)

- CVE-2018-17795:tiff2pdf.cのt2p_write_pdf関数により、リモート攻撃者が細工されたファイルを介してサービス拒否(ヒープベースのバッファオーバーフローおよびアプリケーションクラッシュ)を引き起こしたり、詳細不明なその他の影響を及ぼしたりする可能性があります。この問題はCVE-2017-9935と同様です。
(bsc#1110358)

- CVE-2018-16335:tif_dirread.cのChopUpSingleUncompressedStripでのnewoffsets処理により、リモート攻撃者が細工されたTIFFファイルを介してサービス拒否(ヒープベースのバッファオーバーフローおよびアプリケーションクラッシュ)を引き起こしたり、詳細不明なその他の影響を及ぼしたりする可能性があります。これは、tiff2pdfで実証済みです。これは、CVE-2018-15209 とは異なる脆弱性です。
(bsc#1106853)

この更新はSUSEからインポートされました:SLE-15:更新プロジェクトを更新します。

ソリューション

影響を受ける tiff パッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1092480

https://bugzilla.opensuse.org/show_bug.cgi?id=1106853

https://bugzilla.opensuse.org/show_bug.cgi?id=1108627

https://bugzilla.opensuse.org/show_bug.cgi?id=1108637

https://bugzilla.opensuse.org/show_bug.cgi?id=1110358

プラグインの詳細

深刻度: High

ID: 123354

ファイル名: openSUSE-2019-847.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/3/27

更新日: 2021/1/19

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:libtiff-devel, p-cpe:/a:novell:opensuse:libtiff-devel-32bit, p-cpe:/a:novell:opensuse:libtiff5, p-cpe:/a:novell:opensuse:libtiff5-32bit, p-cpe:/a:novell:opensuse:libtiff5-32bit-debuginfo, p-cpe:/a:novell:opensuse:libtiff5-debuginfo, p-cpe:/a:novell:opensuse:tiff, p-cpe:/a:novell:opensuse:tiff-debuginfo, p-cpe:/a:novell:opensuse:tiff-debugsource, cpe:/o:novell:opensuse:15.0

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/3/23

脆弱性公開日: 2017/6/26

参照情報

CVE: CVE-2017-9935, CVE-2018-10779, CVE-2018-15209, CVE-2018-16335, CVE-2018-17100, CVE-2018-17101, CVE-2018-17795