SUSE SLES11セキュリティ更新プログラム:SDL(SUSE-SU-2019:13998-1)

high Nessus プラグイン ID 123553
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのSUSEホストに1つ以上のセキュリティ更新プログラムがありません。

説明

SDL用のこの更新プログラムでは、以下の問題が修正されます。修正されたセキュリティ問題:CVE-2019-7572:audio/SDL_wave.c内のIMA_ADPCM_nibbleで発生するバッファオーバーリードが修正されました。(bsc#1124806)CVE-2019-7578:audio/SDL_wave.c内のInitIMA_ADPCMで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1125099)CVE-2019-7576:audio/SDL_wave.c内のInitMS_ADPCMで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124799)CVE-2019-7573:audio/SDL_wave.c内のInitMS_ADPCMで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124805)CVE-2019-7635:video/SDL_blit_1.c内のBlit1to4で発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124827)CVE-2019-7636:video/SDL_pixels.c内のSDL_GetRGBで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124826)CVE-2019-7638:video/SDL_pixels.c内のMap1toNで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124824)CVE-2019-7574:audio/SDL_wave.c内のIMA_ADPCM_decodeで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124803)CVE-2019-7575:audio/SDL_wave.cc内のMS_ADPCM_decodeで発生するヒープベースのバッファオーバーフローが修正されました。(bsc#1124802)CVE-2019-7637:SDL_surface.c内のSDL_FillRect関数で発生するヒープベースのバッファオーバーフローが修正されました。(bsc#1124825)CVE-2019-7577:audio/SDL_wave.c内のSDL_LoadWAV_RWで発生するヒープベースのバッファオーバーリードが修正されました。(bsc#1124800)注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。別の方法として、製品にリストされているコマンドを実行することができます:SUSE Linux Enterprise Software Development Kit 11-SP4:zypper in -t patch sdksp4-SDL-13998=1、SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-SDL-13998=1、SUSE Linux Enterprise Point of Sale 11-SP3:zypper in -t patch sleposp3-SDL-13998=1、SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-SDL-13998=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1124799

https://bugzilla.suse.com/show_bug.cgi?id=1124800

https://bugzilla.suse.com/show_bug.cgi?id=1124802

https://bugzilla.suse.com/show_bug.cgi?id=1124803

https://bugzilla.suse.com/show_bug.cgi?id=1124805

https://bugzilla.suse.com/show_bug.cgi?id=1124806

https://bugzilla.suse.com/show_bug.cgi?id=1124824

https://bugzilla.suse.com/show_bug.cgi?id=1124825

https://bugzilla.suse.com/show_bug.cgi?id=1124826

https://bugzilla.suse.com/show_bug.cgi?id=1124827

https://bugzilla.suse.com/show_bug.cgi?id=1125099

https://www.suse.com/security/cve/CVE-2019-7572/

https://www.suse.com/security/cve/CVE-2019-7573/

https://www.suse.com/security/cve/CVE-2019-7574/

https://www.suse.com/security/cve/CVE-2019-7575/

https://www.suse.com/security/cve/CVE-2019-7576/

https://www.suse.com/security/cve/CVE-2019-7577/

https://www.suse.com/security/cve/CVE-2019-7578/

https://www.suse.com/security/cve/CVE-2019-7635/

https://www.suse.com/security/cve/CVE-2019-7636/

https://www.suse.com/security/cve/CVE-2019-7637/

https://www.suse.com/security/cve/CVE-2019-7638/

http://www.nessus.org/u?b4bfb8ca

プラグインの詳細

深刻度: High

ID: 123553

ファイル名: suse_SU-2019-13998-1.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/4/1

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:SDL, cpe:/o:novell:suse_linux:11

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/3/29

脆弱性公開日: 2019/2/7

参照情報

CVE: CVE-2019-7572, CVE-2019-7573, CVE-2019-7574, CVE-2019-7575, CVE-2019-7576, CVE-2019-7577, CVE-2019-7578, CVE-2019-7635, CVE-2019-7636, CVE-2019-7637, CVE-2019-7638