EulerOS 2.0 SP2:SDL(EulerOS-SA-2019-1126)

high Nessus プラグイン ID 123600
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのEulerOSホストに複数のセキュリティ更新プログラムがありません。

説明

インストールされているSDLパッケージのバージョンによると、リモートホストにインストールされているEulerOSは次の脆弱性の影響を受けます。- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、audio/SDL_wave.c(wNumCoefループの外側)のInitMS_ADPCMにヒープベースのバッファオーバーリードがあります。(CVE-2019-7576)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、audio/SDL_wave.cのSDL_LoadWAV_RWにバッファオーバーリードがあります。(CVE-2019-7577)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、audio/SDL_wave.cのInitIMA_ADPCMにヒープベースのバッファオーバーリードがあります。(CVE-2019-7578)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、video/SDL_blit_1.cのBlit1to4にヒープベースのバッファオーバーリードがあります。(CVE-2019-7635)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、video/SDL_pixels.cのSDL_GetRGBにヒープベースのバッファオーバーリードがあります。(CVE-2019-7636)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、video/SDL_surface.cのSDL_FillRectにヒープベースのバッファオーバーフローがあります。(CVE-2019-7637)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、video/SDL_pixels.cのMap1toNにヒープベースのバッファオーバーリードがあります。(CVE-2019-7638)- 1.2.15までおよび2.0.9までの2.xのSDL(Simple DirectMedia Layer)では、audio/SDL_wave.c(wNumCoefループ内)のInitMS_ADPCMにヒープベースのバッファオーバーリードがあります。(CVE-2019-7573)注意:Tenable Network Securityは、前述の記述ブロックをEulerOSセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

影響を受けるSDLパッケージを更新してください。

関連情報

http://www.nessus.org/u?5684e8a6

プラグインの詳細

深刻度: High

ID: 123600

ファイル名: EulerOS_SA-2019-1126.nasl

バージョン: 1.6

タイプ: local

公開日: 2019/4/2

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:huawei:euleros:SDL, p-cpe:/a:huawei:euleros:SDL-devel, cpe:/o:huawei:euleros:2.0

必要な KB アイテム: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

除外される KB アイテム: Host/EulerOS/uvp_version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/3/27

参照情報

CVE: CVE-2019-7573, CVE-2019-7576, CVE-2019-7577, CVE-2019-7578, CVE-2019-7635, CVE-2019-7636, CVE-2019-7637, CVE-2019-7638