FreeBSD:Apache -- 複数の脆弱性(cf2105c6-551b-11e9-b95c-b499baebfeaf)

high Nessus プラグイン ID 123644
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのFreeBSDホストに、セキュリティ関連の更新プログラムがありません。

説明

Apache httpd プロジェクトによる報告:

Apache HTTPサーバのモジュールのスクリプトからの権限昇格(CVE-2019-0211)(重要度高)

mod_auth_digestのアクセス制御のバイパス(CVE-2019-0217)(重要度高)

mod_sslのアクセスコントロールのバイパス(CVE-2019-0215)(重要度高)

mod_http2、最近のアップグレードのクラッシュの可能性(CVE-2019-0197)(重要度低)

mod_http2、文字列比較でのメモリ解放後読み取り(read-after-free)(CVE-2019-0196)(重要度低)

Apache httpdのURL正規化の不一致( CVE-2019-0220)(重要度低)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://www.apache.org/dist/httpd/CHANGES_2.4.39

https://httpd.apache.org/security/vulnerabilities_24.html

http://www.nessus.org/u?bc2f167e

プラグインの詳細

深刻度: High

ID: 123644

ファイル名: freebsd_pkg_cf2105c6551b11e9b95cb499baebfeaf.nasl

バージョン: 1.6

タイプ: local

公開日: 2019/4/3

更新日: 2021/11/30

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.6

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:freebsd:freebsd:apache24, cpe:/o:freebsd:freebsd

必要な KB アイテム: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/4/2

脆弱性公開日: 2019/4/1

参照情報

CVE: CVE-2019-0196, CVE-2019-0211, CVE-2019-0215, CVE-2019-0217, CVE-2019-0220