openSUSEセキュリティ更新プログラム:libcaca(openSUSE-2019-1144)

high Nessus プラグイン ID 123774
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

libcaca用のこの更新プログラムでは、以下の問題が修正されています:修正されたセキュリティ問題:- CVE-2018-20544:caca/dither.cの浮動小数点例外が修正されました(bsc#1120502)- CVE-2018-20545:4bppのcommon-image.cにあるload_image関数のWRITEメモリアクセスを修正しました(bsc#1120584)- CVE-2018-20546:bppのcaca / dither.cにあるget_rgba_default関数のREADメモリアクセスを修正しました(bsc#1120503)- CVE-2018-20547:24bppのcaca / dither.cにあるget_rgba_default関数のREADメモリアクセスを修正しました(bsc#1120504)- CVE-2018-20548:1bppのcommon-image.cにあるload_image関数のWRITEメモリアクセスを修正しました(bsc#1120589)- CVE-2018-20549:caca / file.cのcaca_file_read関数におけるWRITEメモリアクセスを修正しました(bsc#1120470)この更新は、SUSE:SLE-15:Updateの更新プロジェクトからインポートされました。

ソリューション

影響を受けるlibcacaパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1120470

https://bugzilla.opensuse.org/show_bug.cgi?id=1120502

https://bugzilla.opensuse.org/show_bug.cgi?id=1120503

https://bugzilla.opensuse.org/show_bug.cgi?id=1120504

https://bugzilla.opensuse.org/show_bug.cgi?id=1120584

https://bugzilla.opensuse.org/show_bug.cgi?id=1120589

プラグインの詳細

深刻度: High

ID: 123774

ファイル名: openSUSE-2019-1144.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/4/5

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:caca-utils, p-cpe:/a:novell:opensuse:caca-utils-debuginfo, p-cpe:/a:novell:opensuse:libcaca-debugsource, p-cpe:/a:novell:opensuse:libcaca-devel, p-cpe:/a:novell:opensuse:libcaca-ruby, p-cpe:/a:novell:opensuse:libcaca-ruby-debuginfo, p-cpe:/a:novell:opensuse:libcaca0, p-cpe:/a:novell:opensuse:libcaca0-32bit, p-cpe:/a:novell:opensuse:libcaca0-32bit-debuginfo, p-cpe:/a:novell:opensuse:libcaca0-debuginfo, p-cpe:/a:novell:opensuse:libcaca0-plugins, p-cpe:/a:novell:opensuse:libcaca0-plugins-32bit, p-cpe:/a:novell:opensuse:libcaca0-plugins-32bit-debuginfo, p-cpe:/a:novell:opensuse:libcaca0-plugins-debuginfo, p-cpe:/a:novell:opensuse:python3-caca, cpe:/o:novell:opensuse:15.0

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/4/4

脆弱性公開日: 2018/12/28

参照情報

CVE: CVE-2018-20544, CVE-2018-20545, CVE-2018-20546, CVE-2018-20547, CVE-2018-20548, CVE-2018-20549