Oracle Linux 6:java-1.8.0-openjdk(ELSA-2019-0774)

high Nessus プラグイン ID 124133

概要

リモートのOracle Linuxホストに、1つ以上のセキュリティ更新がありません。

説明

出典:Red Hatセキュリティアドバイザリ2019:0774:java-1.8.0-openjdkの更新プログラムが、Red Hat Enterprise Linux 6で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。java-1.8.0-openjdkパッケージには、OpenJDK 8 Java Runtime EnvironmentおよびOpenJDK 8 Javaソフトウェア開発キットが含まれています。セキュリティ修正プログラム:* OpenJDK:setCurrGlyphID()のフォントレイアウトエンジンの範囲外アクセス(2D、8219022)(CVE-2019-2698)* OpenJDK:BigDecimalからlongへの変換が遅い(Libraries、8211936)(CVE-2019-2602)* OpenJDK:RMIレジストリサーバー側のディスパッチ処理における誤ったスケルトンの選択(RMI、8218453)(CVE-2019-2684)影響、CVSSスコア、謝辞、その他の関連情報を含むセキュリティ問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。バグ修正プログラム:* coalesce.cppのアサートエラー:スピルできないアイテムをスピルしようとしました(BZ #1640127)

ソリューション

影響を受けるjava-1.8.0-openjdkパッケージを更新してください。

関連情報

https://oss.oracle.com/pipermail/el-errata/2019-April/008656.html

プラグインの詳細

深刻度: High

ID: 124133

ファイル名: oraclelinux_ELSA-2019-0774.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/4/18

更新日: 2019/9/27

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:oracle:linux:java-1.8.0-openjdk, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-debug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-demo, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-demo-debug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-devel, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-devel-debug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-headless, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-headless-debug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-javadoc, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-javadoc-debug, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-src, p-cpe:/a:oracle:linux:java-1.8.0-openjdk-src-debug, cpe:/o:oracle:linux:6

必要な KB アイテム: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/4/17

脆弱性公開日: 2019/4/23

参照情報

CVE: CVE-2019-2602, CVE-2019-2684, CVE-2019-2698

RHSA: 2019:0774