openSUSEセキュリティ更新プログラム:gnutls(openSUSE-2019-1353)

medium Nessus プラグイン ID 124714

Language:

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

gnutlsをバージョン3.6.7に更新するこのプログラムは、以下の問題が修正されています:

修正されたセキュリティ問題:

- CVE-2019-3836:不正な形式のTLS1.3非同期メッセージを介した無効なポインターアクセスを修正しました(bsc#1130682)。

- CVE-2019-3829:証明書検証APIの二重解放に関する脆弱性を修正しました(bsc#1130681)。

- CVE-2018-16868:PKCS#1 v1.5の検証とパディングoracleの検証におけるBleichenbacher方式のサイドチャンネル漏洩を修正しました(bsc#1118087)。

修正された非セキュリティ問題:

- TLS 1.3をサポートするためにgnutlsを更新します(fate#327114)

この更新はSUSEからインポートされました:SLE-15:更新プロジェクトを更新します。

ソリューション

影響を受けるgnutlsパッケージを更新してください。

参考資料

https://bugzilla.opensuse.org/show_bug.cgi?id=1118087

https://bugzilla.opensuse.org/show_bug.cgi?id=1130681

https://bugzilla.opensuse.org/show_bug.cgi?id=1130682

https://features.opensuse.org/327114

プラグインの詳細

深刻度: Medium

ID: 124714

ファイル名: openSUSE-2019-1353.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/5/9

更新日: 2024/5/24

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Low

基本値: 3.3

現状値: 2.6

ベクトル: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:N

CVSS スコアのソース: CVE-2018-16868

CVSS v3

リスクファクター: Medium

基本値: 5.6

現状値: 5.1

ベクトル: CVSS:3.0/AV:P/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:gnutls-guile-debuginfo, p-cpe:/a:novell:opensuse:libgnutls-dane-devel, p-cpe:/a:novell:opensuse:libgnutls-devel, p-cpe:/a:novell:opensuse:libgnutls-devel-32bit, p-cpe:/a:novell:opensuse:libgnutlsxx28-debuginfo, p-cpe:/a:novell:opensuse:gnutls, p-cpe:/a:novell:opensuse:libgnutls30-32bit, cpe:/o:novell:opensuse:15.0, p-cpe:/a:novell:opensuse:libgnutls30, p-cpe:/a:novell:opensuse:gnutls-guile, p-cpe:/a:novell:opensuse:libgnutlsxx28, p-cpe:/a:novell:opensuse:libgnutls30-32bit-debuginfo, p-cpe:/a:novell:opensuse:libgnutls-dane0, p-cpe:/a:novell:opensuse:gnutls-debugsource, p-cpe:/a:novell:opensuse:libgnutls-dane0-debuginfo, p-cpe:/a:novell:opensuse:libgnutlsxx-devel, p-cpe:/a:novell:opensuse:gnutls-debuginfo, p-cpe:/a:novell:opensuse:libgnutls30-debuginfo

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/5/8

脆弱性公開日: 2018/12/3

参照情報

CVE: CVE-2018-16868, CVE-2019-3829, CVE-2019-3836