Amazon Linux 2:java-1.7.0-openjdk(ALAS-2019-1209)

high Nessus プラグイン ID 125288
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのAmazon Linux 2ホストに、セキュリティ更新プログラムがありません。

説明

Oracle Java SEのJava SE、Java SE Embeddedコンポーネントの脆弱性(サブコンポーネント:ライブラリ)。サポートされているバージョンで影響を受けるのは、Java SE:7u211、8u202、11.0.2、12;Java SE Embedded:8u201です。容易に悪用可能な脆弱性を使用して、認証されていない攻撃者が複数のプロトコルを介してネットワークにアクセスし、Java SEやJava SE Embeddedを侵害する可能性があります。この脆弱性を利用した攻撃に成功すると、権限なしにJava SEとJava SE Embeddedをハングさせたり、頻繁にクラッシュを繰り返したりする(完全なDOS)可能性があります。注意:この脆弱性は、信頼できないJava Web Startアプリケーションや信頼できないJavaアプレット(Webサービスなど)を使用せずに、指定されたコンポーネントのAPIにデータを提供するだけで悪用される可能性があります。CVSS 3.0ベーススコア7.5(可用性に影響)。CVSSベクトル:(CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)(CVE-2019-2602)Oracle Java SEのJava SEコンポーネントの脆弱性(サブコンポーネント:2D)。サポートされているバージョンで影響を受けるのは、Java SE:7u211および8u202。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Java SEを侵害する可能性があります。この脆弱性への攻撃が成功した場合、Java SEの乗っ取りが発生する可能性があります。注意:この脆弱性が該当するのは、通常サンドボックス化されたJava Web Startアプリケーションまたはサンドボックス化されたJavaアプレットを(Java SE 8で)実行しているクライアントで、信頼できないコード(インターネットからのコードなど)を読み込んで実行し、セキュリティをJavaサンドボックスに依存しているJavaデプロイメントです。この脆弱性は、通常サーバーで信頼できるコード(管理者がインストールしたコードなど)のみを読み込んで実行するJavaデプロイメントには存在しません。CVSS 3.0ベーススコア8.1(機密性、整合性、可用性への影響)CVSSベクトル:(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)。(CVE-2019-2698)Java SE、Oracle Java SEのJava SE Embeddedコンポーネントの脆弱性(サブコンポーネント:RMI)。サポートされているバージョンで影響を受けるのは、Java SE:7u211、8u202、11.0.2、12;Java SE Embedded:8u201です。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを介してネットワークにアクセスし、Java SE、Java SE Embeddedを侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータやJava SE、Java SE Embeddedがアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があります。注意:この脆弱性が該当するのは、通常サンドボックス化されたJava Web Startアプリケーションまたはサンドボックス化されたJavaアプレットを(Java SE 8で)実行しているクライアントで、信頼できないコード(インターネットからのコードなど)を読み込んで実行し、セキュリティをJavaサンドボックスに依存しているJavaデプロイメントです。この脆弱性は、たとえばAPIにデータを提供するWebサービスを通して、指定されたコンポーネント内のAPIを使用することによって悪用される可能性もあります。CVSS 3.0ベーススコア5.9(整合性への影響)CVSSベクトル:(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N)(CVE-2019-2684)

ソリューション

「yum update java-1.7.0-openjdk」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2/ALAS-2019-1209.html

プラグインの詳細

深刻度: High

ID: 125288

ファイル名: al2_ALAS-2019-1209.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2019/5/21

更新日: 2019/7/10

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:java-1.7.0-openjdk, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-accessibility, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-debuginfo, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-demo, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-devel, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-headless, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-javadoc, p-cpe:/a:amazon:linux:java-1.7.0-openjdk-src, cpe:/o:amazon:linux:2

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/5/20

脆弱性公開日: 2019/4/23

参照情報

CVE: CVE-2019-2602, CVE-2019-2684, CVE-2019-2698

ALAS: 2019-1209