RHEL 7:dotNET(RHSA-2019:1236)

high Nessus プラグイン ID 125322
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストに1つまたは複数のセキュリティ更新プログラムがありません。

説明

rh-dotnetcore10-dotnetcore、rh-dotnetcore11-dotnetcore、rh-dotnet21-dotnet、rh-dotnet22-dotnet、rh-dotnet22-curlの更新プログラムが、Red Hat Enterprise Linux 7の.NET Coreで利用可能になりました。Red Hat製品セキュリティは、この更新プログラムがセキュリティに及ぼす影響の重要度を中と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。.NET Coreは管理されたソフトウェアフレームワークです。これは、.NET Framework APIといくつかの新しいAPIのサブセットを実装し、CLR実装が含まれています。セキュリティ上の脆弱性に対処する新しいバージョンの.NET Coreが利用可能になりました。更新されたバージョンは、.NET Core 1.0.16、1.1.13、2.1.11、2.2.5です。セキュリティ修正プログラム:* dotNET:正規表現のタイムアウトが強制されません(CVE-2019-0820)* dotNET:ASP.Netコアサービス拒否を引き起こすURI.TryCreate内の無限ループ(CVE-2019-0980)* dotNET:ASP.Netコアサービス拒否を引き起こすIPAddress.TryCreate内のクラッシュ(CVE-2019-0981)影響、CVSSスコア、謝辞、その他の関連情報を含むセキュリティ問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。バグ修正プログラム:* rh-dotnet22-dotnetでbash補完を再度有効にする(BZ#1654863)* CentOSでrh-dotnet22-curlを再構築する際のエラー(BZ#1678932)* DOTNET_ROOTの設定解除により破損したapphost(BZ#1703479)* bash補完をrh-dotnet22パッケージと互換性のあるものにする(BZ#1705259)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/

https://access.redhat.com/errata/RHSA-2019:1236

https://access.redhat.com/security/cve/cve-2019-0820

https://access.redhat.com/security/cve/cve-2019-0980

https://access.redhat.com/security/cve/cve-2019-0981

プラグインの詳細

深刻度: High

ID: 125322

ファイル名: redhat-RHSA-2019-1236.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/5/22

更新日: 2020/1/15

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:rh-dotnet21, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-dotnet, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-dotnet-debuginfo, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-dotnet-host, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-dotnet-runtime-2.1, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-dotnet-sdk-2.1, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-dotnet-sdk-2.1.5xx, p-cpe:/a:redhat:enterprise_linux:rh-dotnet21-runtime, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-curl, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-curl-debuginfo, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet-debuginfo, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet-host, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet-host-fxr-2.2, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet-runtime-2.2, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet-sdk-2.2, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-dotnet-sdk-2.2.1xx, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-libcurl, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-libcurl-devel, p-cpe:/a:redhat:enterprise_linux:rh-dotnet22-runtime, p-cpe:/a:redhat:enterprise_linux:rh-dotnetcore10-dotnetcore, p-cpe:/a:redhat:enterprise_linux:rh-dotnetcore10-dotnetcore-debuginfo, p-cpe:/a:redhat:enterprise_linux:rh-dotnetcore11-dotnetcore, p-cpe:/a:redhat:enterprise_linux:rh-dotnetcore11-dotnetcore-debuginfo, cpe:/o:redhat:enterprise_linux:7

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/5/15

脆弱性公開日: 2019/5/16

参照情報

CVE: CVE-2019-0820, CVE-2019-0980, CVE-2019-0981

RHSA: 2019:1236