Apache ZooKeeper < 3.4.14/3.5.x < 3.5.5の情報漏えい

medium Nessus プラグイン ID 125635
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのApache ZooKeeperサーバーは、情報漏えいの脆弱性の影響を受けます。

説明

リモートホストで待機しているApache ZooKeeperのバージョンは、3.4.14より前、または3.5.5より前の3.5.xです。したがって、リクエスタの権限をチェックしていないために、ZooKeeperのgetACL()コマンドで情報漏えいの脆弱性の影響を受けます。認証されていないリモートの攻撃者がこれを悪用し、秘密情報を漏えいさせる可能性があります。

ソリューション

Apache ZooKeeper 3.4.14または3.5.5以降にアップデートしてください。

関連情報

https://zookeeper.apache.org/security.html

https://issues.apache.org/jira/browse/ZOOKEEPER-1392

プラグインの詳細

深刻度: Medium

ID: 125635

ファイル名: apache_zookeeper_3_5_5.nasl

バージョン: 1.2

タイプ: combined

ファミリー: Misc.

公開日: 2019/5/31

更新日: 2019/10/18

依存関係: apache_zookeeper_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2019-0201

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:zookeeper

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/5/23

脆弱性公開日: 2019/5/23

参照情報

CVE: CVE-2019-0201

BID: 104253

IAVB: 2019-B-0041