SUSE SLED12 / SLES12セキュリティ更新プログラム:libcroco(SUSE-SU-2019:1468-1)

high Nessus プラグイン ID 125873

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このlibcrocoの更新では、次の問題が修正されています:

修正されたセキュリティ問題:

CVE-2017-7960:ヒープオーバーフローを修正しました(input:バイトを読み込む前に入力の終了をチェックします)(bsc#1034481)。

CVE-2017-7961:未定義の動作を修正しました(tknzr:max long rgb値のみをサポートします)(bsc#1034482)。

CVE-2017-8834:細工されたCSSファイルを介したサービス拒否(メモリ割り当てエラー)を修正しました(bsc#1043898)。

CVE-2017-8871:細工されたJavaScriptファイルを介したサービス拒否(無限ループおよびCPU消費)を修正しました(bsc#1043899)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterpriseソフトウェア開発キット12-SP4:zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1468=1

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-1468=1

SUSE Linux Enterprise Server 12-SP4:zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1468=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-1468=1

SUSE Linux Enterprise Desktop 12-SP4:zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-1468=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2019-1468=1

SUSE CaaS Platform ALL:

この更新プログラムをインストールするには、SUSE CaaS Platform Velumダッシュボードを使用してください。新しい更新を検出した場合は通知され、その後、制御された方法でクラスター全体の更新をトリガーできます。

SUSE CaaS Platform 3.0:

この更新プログラムをインストールするには、SUSE CaaS Platform Velumダッシュボードを使用してください。新しい更新を検出した場合は通知され、その後、制御された方法でクラスター全体の更新をトリガーできます。

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-1468=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1034481

https://bugzilla.suse.com/show_bug.cgi?id=1034482

https://bugzilla.suse.com/show_bug.cgi?id=1043898

https://bugzilla.suse.com/show_bug.cgi?id=1043899

https://www.suse.com/security/cve/CVE-2017-7960/

https://www.suse.com/security/cve/CVE-2017-7961/

https://www.suse.com/security/cve/CVE-2017-8834/

https://www.suse.com/security/cve/CVE-2017-8871/

http://www.nessus.org/u?2aba300d

プラグインの詳細

深刻度: High

ID: 125873

ファイル名: suse_SU-2019-1468-1.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/6/13

更新日: 2021/1/13

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2017-7961

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libcroco-0_6, p-cpe:/a:novell:suse_linux:libcroco-0_6-3, p-cpe:/a:novell:suse_linux:libcroco-0_6-3-debuginfo, p-cpe:/a:novell:suse_linux:libcroco-debuginfo, p-cpe:/a:novell:suse_linux:libcroco-debugsource, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/6/12

脆弱性公開日: 2017/4/19

参照情報

CVE: CVE-2017-7960, CVE-2017-7961, CVE-2017-8834, CVE-2017-8871