SUSE SLED15/SLES15セキュリティ更新プログラム:java-1_8_0-ibm(SUSE-SUSE-SU-2019:1308-2)

high Nessus プラグイン ID 126336
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このjava-1_8_0-ibmの更新プログラムでは、次の問題が修正されています:Java 8.0 Service Refresh 5 Fix Pack 35に更新してください。修正されたセキュリティ問題:CVE-2019-10245:クラッシュを引き起こすJavaバイトコード検証機能の問題を修正しました(bsc#1134718)。CVE-2019-2698:2Dコンポーネントの領域外アクセスの問題を修正しました(bsc#1132729)。CVE-2019-2697:2Dコンポーネント内の欠陥を修正しました(bsc#1132734)。CVE-2019-2602:BigDecimal実装内の欠陥を修正しました(コンポーネント:ライブラリ)(bsc#1132728)。CVE-2019-2684:RMIレジストリの実装で見つかった欠陥を修正しました(bsc#1132732)。注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。別の方法として、製品にリストされているコマンドを実行することができます:SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1308=1 SUSE Linux Enterprise Module for Legacy Software 15-SP1:zypper in -t patch SUSE-SLE-Module-Legacy-15-SP1-2019-1308=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1132728

https://bugzilla.suse.com/show_bug.cgi?id=1132729

https://bugzilla.suse.com/show_bug.cgi?id=1132732

https://bugzilla.suse.com/show_bug.cgi?id=1132734

https://bugzilla.suse.com/show_bug.cgi?id=1134718

https://www.suse.com/security/cve/CVE-2019-10245/

https://www.suse.com/security/cve/CVE-2019-2602/

https://www.suse.com/security/cve/CVE-2019-2684/

https://www.suse.com/security/cve/CVE-2019-2697/

https://www.suse.com/security/cve/CVE-2019-2698/

http://www.nessus.org/u?e286dda3

プラグインの詳細

深刻度: High

ID: 126336

ファイル名: suse_SU-2019-1308-2.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/6/28

更新日: 2021/1/13

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:java-1_8_0-ibm, p-cpe:/a:novell:suse_linux:java-1_8_0-ibm-alsa, p-cpe:/a:novell:suse_linux:java-1_8_0-ibm-demo, p-cpe:/a:novell:suse_linux:java-1_8_0-ibm-devel, p-cpe:/a:novell:suse_linux:java-1_8_0-ibm-plugin, p-cpe:/a:novell:suse_linux:java-1_8_0-ibm-src, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/6/27

脆弱性公開日: 2019/4/19

参照情報

CVE: CVE-2019-10245, CVE-2019-2602, CVE-2019-2684, CVE-2019-2697, CVE-2019-2698