RHEL 7:libarchive(RHSA-2019:2298)

high Nessus プラグイン ID 127709
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

libarchiveの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。libarchive プログラミングライブラリは、GNU tar、cpio、ISO 9660 CD-ROM 画像などの、いくつかの異なるストリーミングアーカイブフォーマットを作成して読み取る可能性があります。Libarchive は特に、bsdtar ユーティリティ、python-libarchive などのスクリプト言語バインディング、およびいくつかの人気のあるデスクトップファイルマネージャーで使用されています。セキュリティ修正プログラム:* libarchive:RARデコーダーの二重解放によりサービス拒否が発生(CVE-2018-1000877)* libarchive:RARデコーダーのメモリ解放後使用(Use After Free)によりサービス拒否が発生(CVE-2018-1000878)* libarchive:archive_read_support_format_7zip.cの領域外読み取りによりサービス拒否が発生(CVE-2019-1000019)* libarchive:archive_read_support_format_iso9660.cの無限再帰によりサービス拒否が発生(CVE-2019-1000020)* libarchive:lha_read_data_noneの領域外読み取り(CVE-2017-14503)影響、CVSSスコア、謝辞、その他の関連情報を含むセキュリティ問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。追加の変更:このリリースの変更に関する詳細については、「参照」セクションにリンクされている『Red Hat Enterprise Linux 7.6リリースノート』を参照してください。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?3395ff0b

https://access.redhat.com/errata/RHSA-2019:2298

https://access.redhat.com/security/cve/cve-2017-14503

https://access.redhat.com/security/cve/cve-2018-1000877

https://access.redhat.com/security/cve/cve-2018-1000878

https://access.redhat.com/security/cve/cve-2019-1000019

https://access.redhat.com/security/cve/cve-2019-1000020

プラグインの詳細

深刻度: High

ID: 127709

ファイル名: redhat-RHSA-2019-2298.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/8/12

更新日: 2020/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:bsdcpio, p-cpe:/a:redhat:enterprise_linux:bsdtar, p-cpe:/a:redhat:enterprise_linux:libarchive, p-cpe:/a:redhat:enterprise_linux:libarchive-debuginfo, p-cpe:/a:redhat:enterprise_linux:libarchive-devel, cpe:/o:redhat:enterprise_linux:7

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/8/6

脆弱性公開日: 2017/9/17

参照情報

CVE: CVE-2017-14503, CVE-2018-1000877, CVE-2018-1000878, CVE-2019-1000019, CVE-2019-1000020

RHSA: 2019:2298