Exim < 4.92.1 Input-ValidationのRCE

critical Nessus プラグイン ID 128036
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのメールサーバーは、リモートでコードが実行される脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストで実行されているEximのバージョンは、4.92.1より前です。したがって、「$ {sort}」展開における入力検証の欠陥に影響する可能性があります。リモートの攻撃者が任意のコードを実行する可能性があります。デフォルトの構成に「$ {sort}」が含まれていないことに注意してください。

ソリューション

Exim 4.92.1以降にアップグレードしてください。

関連情報

https://exim.org/static/doc/security/CVE-2019-13917.txt

https://ftp.exim.org/pub/exim/exim4/ChangeLog

プラグインの詳細

深刻度: Critical

ID: 128036

ファイル名: exim_4_92_1.nasl

バージョン: 1.3

タイプ: remote

ファミリー: SMTP problems

公開日: 2019/8/20

更新日: 2019/10/17

依存関係: smtpserver_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2019-13917

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:exim:exim

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/7/18

脆弱性公開日: 2019/7/18

参照情報

CVE: CVE-2019-13917

BID: 109338