SUSE SLES12セキュリティ更新プログラム:nodejs10(SUSE-SU-2019:2254-1)(0-Length Headers Leak)(Data Dribble)(Empty Frames Flood)(Internal Data Buffering)(Ping Flood)(Reset Flood)(Resource Loop)(Settings Flood)

high Nessus プラグイン ID 128411

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このnodejs10のバージョン10.16.3への更新では、次の問題が修正されます:

キャッシュサイドチャネル攻撃の軽減:

CVE-2019-9511:ウィンドウサイズの操作やストリーム優先度の操作に対して脆弱であり、サービス拒否を引き起こす可能性のあるHTTP/2実装を修正しました(bsc#1146091)。

CVE-2019-9512:無制限のメモリ増加につながるPINGフレームを使用したHTTP/2フラッドを修正します(bsc#1146099)。

CVE-2019-9513:サービス拒否につながる可能性のあるリソースループに対して脆弱なHTTP/2実装を修正しました。
(bsc#1146094)。

CVE-2019-9514:サービス拒否につながる可能性のある、HTTP/2実装がリセットフラッドに対して脆弱である問題を修正しました(bsc#1146095)。

CVE-2019-9515:無制限のメモリ増加につながるSETTINGSフレームを使用したHTTP/2フラッドを修正します(bsc#1146100)。

CVE-2019-9516:サービス拒否につながる可能性のあるヘッダーリークに対して脆弱なHTTP/2実装を修正しました(bsc#1146090)。

CVE-2019-9517:制約のない内部データバッファリングに対して脆弱なHTTP/2実装を修正しました(bsc#1146097)。

CVE-2019-9518:サービス拒否につながる可能性のある空のフレームのフラッドに対して脆弱なHTTP/2実装を修正しました(bsc#1146093)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Module for Web Scripting 12:zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2019-2254=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1146090

https://bugzilla.suse.com/show_bug.cgi?id=1146091

https://bugzilla.suse.com/show_bug.cgi?id=1146093

https://bugzilla.suse.com/show_bug.cgi?id=1146094

https://bugzilla.suse.com/show_bug.cgi?id=1146095

https://bugzilla.suse.com/show_bug.cgi?id=1146097

https://bugzilla.suse.com/show_bug.cgi?id=1146099

https://bugzilla.suse.com/show_bug.cgi?id=1146100

https://www.suse.com/security/cve/CVE-2019-9511/

https://www.suse.com/security/cve/CVE-2019-9512/

https://www.suse.com/security/cve/CVE-2019-9513/

https://www.suse.com/security/cve/CVE-2019-9514/

https://www.suse.com/security/cve/CVE-2019-9515/

https://www.suse.com/security/cve/CVE-2019-9516/

https://www.suse.com/security/cve/CVE-2019-9517/

https://www.suse.com/security/cve/CVE-2019-9518/

http://www.nessus.org/u?c8330484

プラグインの詳細

深刻度: High

ID: 128411

ファイル名: suse_SU-2019-2254-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2019/8/30

更新日: 2019/12/31

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 5.8

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:nodejs10, p-cpe:/a:novell:suse_linux:nodejs10-debuginfo, p-cpe:/a:novell:suse_linux:nodejs10-debugsource, p-cpe:/a:novell:suse_linux:nodejs10-devel, p-cpe:/a:novell:suse_linux:npm10, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/8/29

脆弱性公開日: 2019/8/13

参照情報

CVE: CVE-2019-9511, CVE-2019-9512, CVE-2019-9513, CVE-2019-9514, CVE-2019-9515, CVE-2019-9516, CVE-2019-9517, CVE-2019-9518