SUSE SLED15 / SLES15セキュリティ更新プログラム:ghostscript(SUSE-SU-2019:2460-1)

critical Nessus プラグイン ID 129381

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このghostscript用の更新プログラムでは、次の問題を修正します:

キャッシュサイドチャネル攻撃の軽減:

CVE-2019-3835:利用可能なsuperexec演算子により引き起こされる不正なファイルシステムアクセスを修正しました。(bsc#1129180)

CVE-2019-3839:利用可能なprivileged演算子により引き起こされる不正なファイルシステムアクセスを修正しました。(bsc#1134156)

CVE-2019-12973:OpenJPEG関数opj_t1_encode_cblksでのサービス拒否の脆弱性を修正しました。(bsc#1140359)

CVE-2019-14811:.pdf_hook_DSC_Creatorの.forceputエクスポージャーによるより安全なモードのバイパスを修正しました。(bsc#1146882)

CVE-2019-14812:setuserparamsの.forceputエクスポージャーによる、より安全なモードのバイパスを修正しました。(bsc#1146882)

CVE-2019-14813:setsystemparamsの.forceputエクスポージャーによる、より安全なモードのバイパスを修正しました。(bsc#1146882)

CVE-2019-14817:.pdfexectokenおよびその他のプロシージャーの.forceputエクスポージャーによるより安全なモードのバイパスを修正しました。(bsc#1146884)

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2460=1

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcpのバージョン。zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2460=1

SUSE Linux Enterprise Module for Basesystem 15-SP1:zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2460=1

SUSE Linux Enterprise Module for Basesystem 15:zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-2460=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1129180

https://bugzilla.suse.com/show_bug.cgi?id=1129186

https://bugzilla.suse.com/show_bug.cgi?id=1134156

https://bugzilla.suse.com/show_bug.cgi?id=1140359

https://bugzilla.suse.com/show_bug.cgi?id=1146882

https://bugzilla.suse.com/show_bug.cgi?id=1146884

https://www.suse.com/security/cve/CVE-2019-12973/

https://www.suse.com/security/cve/CVE-2019-14811/

https://www.suse.com/security/cve/CVE-2019-14812/

https://www.suse.com/security/cve/CVE-2019-14813/

https://www.suse.com/security/cve/CVE-2019-14817/

https://www.suse.com/security/cve/CVE-2019-3835/

https://www.suse.com/security/cve/CVE-2019-3839/

http://www.nessus.org/u?4e6b42cd

プラグインの詳細

深刻度: Critical

ID: 129381

ファイル名: suse_SU-2019-2460-1.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2019/9/26

更新日: 2022/1/26

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2019-14813

VPR

リスクファクター: High

スコア: 8.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:ghostscript, p-cpe:/a:novell:suse_linux:ghostscript-debuginfo, p-cpe:/a:novell:suse_linux:ghostscript-debugsource, p-cpe:/a:novell:suse_linux:ghostscript-devel, p-cpe:/a:novell:suse_linux:ghostscript-mini, p-cpe:/a:novell:suse_linux:ghostscript-mini-debuginfo, p-cpe:/a:novell:suse_linux:ghostscript-mini-debugsource, p-cpe:/a:novell:suse_linux:ghostscript-mini-devel, p-cpe:/a:novell:suse_linux:ghostscript-x11, p-cpe:/a:novell:suse_linux:ghostscript-x11-debuginfo, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/9/25

脆弱性公開日: 2019/3/25

参照情報

CVE: CVE-2019-3835, CVE-2019-3839, CVE-2019-12973, CVE-2019-14811, CVE-2019-14812, CVE-2019-14813, CVE-2019-14817

IAVB: 2019-B-0081-S