Exim 4.92.x < 4.92.3のヒープバッファオーバーフロー

critical Nessus プラグイン ID 129470

概要

リモートのメールサーバーは、リモートでコードが実行される脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストで実行されているEximのバージョンは4.92.3より前の4.92.xです。したがって、リモートでコードが実行される脆弱性の影響を受ける可能性があり、認証されていないリモートの攻撃者がstring_vformatでヒープバッファオーバーフローを介して任意のコードを実行する可能性があります。

ソリューション

Exim4.92.3以降にアップグレードしてください。

関連情報

https://www.exim.org/static/doc/security/CVE-2019-16928.txt

プラグインの詳細

深刻度: Critical

ID: 129470

ファイル名: exim_4_92_3.nasl

バージョン: 1.8

タイプ: remote

ファミリー: SMTP problems

公開日: 2019/9/30

更新日: 2022/3/8

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-16928

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:exim:exim

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/9/27

脆弱性公開日: 2019/9/27

CISAの既知の悪用日: 2022/3/17

参照情報

CVE: CVE-2019-16928