RHEL 8 :nodejs:10(RHSA-2019:2925)(0-Length Headers Leak)(Data Dribble)(Empty Frames Flood)(Internal Data Buffering)(Ping Flood)(Reset Flood)(Resource Loop)(Settings Flood)

high Nessus プラグイン ID 129480

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

nodejs:10モジュールの更新プログラムが、Red Hat Enterprise Linux 8で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。Node.jsは、高速でスケーラブルなネットワークアプリケーションをJavaScriptプログラミング言語でビルドするためのソフトウェア開発プラットフォームです。次のパッケージが新しいアップストリームバージョンにアップグレードされました:nodejs (10.16.3)。セキュリティ修正プログラム:* HTTP/2:大量のデータリクエストにより、サービス拒否が引き起こされる(CVE-2019-9511)* HTTP/2:PINGフレームを使用したフラッドにより、メモリが無制限に増加する(CVE-2019-9512)* HTTP/2:PRIORITYフレームを使用したフラッドにより、リソースが過剰に消費される(CVE-2019-9513)* HTTP/2:HEADERSフレームを使用したフラッドにより、メモリが無制限に増加する(CVE-2019-9514)* HTTP/2:SETTINGSフレームを使用したフラッドにより、メモリが無制限に増加する(CVE-2019-9515)* HTTP/2:長さゼロのヘッダーにより、サービス拒否が引き起こされる(CVE-2019-9516)* HTTP/2:大きな応答のリクエストにより、サービス拒否が引き起こされる(CVE- 2019-9517)* HTTP/2:空のフレームを使用したフラッドにより、リソースが過剰に消費される(CVE-2019-9518)影響、CVSSスコア、謝辞その他の関連情報を含むセキュリティ問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://access.redhat.com/errata/RHSA-2019:2925

https://access.redhat.com/security/cve/cve-2019-9511

https://access.redhat.com/security/cve/cve-2019-9512

https://access.redhat.com/security/cve/cve-2019-9513

https://access.redhat.com/security/cve/cve-2019-9514

https://access.redhat.com/security/cve/cve-2019-9515

https://access.redhat.com/security/cve/cve-2019-9516

https://access.redhat.com/security/cve/cve-2019-9517

https://access.redhat.com/security/cve/cve-2019-9518

プラグインの詳細

深刻度: High

ID: 129480

ファイル名: redhat-RHSA-2019-2925.nasl

バージョン: 1.9

タイプ: local

エージェント: unix

公開日: 2019/10/1

更新日: 2024/4/22

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

基本値: 7.8

現状値: 5.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS スコアのソース: CVE-2019-9518

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:nodejs, p-cpe:/a:redhat:enterprise_linux:nodejs-debugsource, p-cpe:/a:redhat:enterprise_linux:nodejs-devel, p-cpe:/a:redhat:enterprise_linux:nodejs-docs, p-cpe:/a:redhat:enterprise_linux:nodejs-nodemon, p-cpe:/a:redhat:enterprise_linux:nodejs-packaging, p-cpe:/a:redhat:enterprise_linux:npm, cpe:/o:redhat:enterprise_linux:8, cpe:/o:redhat:enterprise_linux:8.0

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/9/30

脆弱性公開日: 2019/8/13

参照情報

CVE: CVE-2019-9511, CVE-2019-9512, CVE-2019-9513, CVE-2019-9514, CVE-2019-9515, CVE-2019-9516, CVE-2019-9517, CVE-2019-9518

RHSA: 2019:2925