PHP 7.4.x < 7.4.0の複数の脆弱性

critical Nessus プラグイン ID 131732
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストにインストールされているアプリケーションは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.4.0より前の7.4.xです。したがって、バッファオーバーフローなどの複数の脆弱性の影響を受けます。

ソリューション

PHPバージョン7.4.0以降にアップグレードしてください。

関連情報

https://www.php.net/ChangeLog-7.php#7.4

https://bugs.php.net/bug.php?id=72530

プラグインの詳細

深刻度: Critical

ID: 131732

ファイル名: php_7_4_0.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2019/12/6

更新日: 2020/3/6

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2019-11043

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.2

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:F/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.1

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/8/29

脆弱性公開日: 2019/8/29

エクスプロイト可能

Metasploit (PHP-FPM Underflow RCE)

参照情報

CVE: CVE-2019-11041, CVE-2019-11042, CVE-2019-11043