RHEL 7:kpatch-patch(RHSA-2020:0027)

high Nessus プラグイン ID 132686

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 7ホストにインストールされているパッケージは、RHSA-2020: 0027アドバイザリに記載されている複数の脆弱性の影響を受けます。

- Kernel:KVM: mmioリングバッファを介したOOBメモリアクセス(CVE-2019-14821)

- kernel: ローカルの攻撃者が複数のメモリ解放後使用(Use After Free)条件をトリガーして、権限を昇格させる可能性があります(CVE-2019-15239)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/416.html

https://cwe.mitre.org/data/definitions/787.html

https://access.redhat.com/security/cve/CVE-2019-14821

https://access.redhat.com/security/cve/CVE-2019-15239

https://access.redhat.com/errata/RHSA-2020:0027

https://bugzilla.redhat.com/1746708

https://bugzilla.redhat.com/1747353

プラグインの詳細

深刻度: High

ID: 132686

ファイル名: redhat-RHSA-2020-0027.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2020/1/7

更新日: 2022/5/18

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2019-15239

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:rhel_aus:7.7, cpe:/o:redhat:rhel_e4s:7.6, cpe:/o:redhat:rhel_e4s:7.7, cpe:/o:redhat:rhel_eus:7.7, cpe:/o:redhat:rhel_tus:7.7, p-cpe:/a:redhat:enterprise_linux:kpatch-patch-3_10_0-1062, p-cpe:/a:redhat:enterprise_linux:kpatch-patch-3_10_0-1062_1_1, p-cpe:/a:redhat:enterprise_linux:kpatch-patch-3_10_0-1062_1_2, p-cpe:/a:redhat:enterprise_linux:kpatch-patch-3_10_0-1062_4_1, p-cpe:/a:redhat:enterprise_linux:kpatch-patch-3_10_0-1062_4_2, p-cpe:/a:redhat:enterprise_linux:kpatch-patch-3_10_0-1062_4_3

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/1/6

脆弱性公開日: 2019/8/20

参照情報

CVE: CVE-2019-14821, CVE-2019-15239

RHSA: 2020:0027

CWE: 416, 787