Amazon Linux 2:oniguruma(ALAS-2020-1380)

critical Nessus プラグイン ID 132735

概要

リモートのAmazon Linux 2ホストに、セキュリティ更新プログラムがありません。

説明

6.9.3より前のOnigurumaによって、regparse.cで再帰が発生するため、regcomp.cでスタックが枯渇する可能性があります。(CVE-2019-16163)6.9.3までのOnigurumaには、PHP 7.3.xやその他の製品で使用された場合、regexec.cのstr_lower_case_matchにヒープベースのバッファオーバーリードがあります。(CVE-2019-19246)

ソリューション

「yum update oniguruma」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2/ALAS-2020-1380.html

プラグインの詳細

深刻度: Critical

ID: 132735

ファイル名: al2_ALAS-2020-1380.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2020/1/9

更新日: 2020/1/13

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:oniguruma, p-cpe:/a:amazon:linux:oniguruma-debuginfo, p-cpe:/a:amazon:linux:oniguruma-devel, cpe:/o:amazon:linux:2

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/1/8

脆弱性公開日: 2019/9/9

参照情報

CVE: CVE-2019-16163, CVE-2019-19012, CVE-2019-19204, CVE-2019-19246

ALAS: 2020-1380