SUSE SLED15 / SLES15セキュリティ更新プログラム:pdsh、slurm_18_08(SUSE-SU-2020:0443-1)

high Nessus プラグイン ID 134036

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このpdsh、slurm_18_08の更新では、次の問題を修正します:

Slurmは、「slurm_18_08」パッケージとして、18.08リリースに含まれていました。バージョン18.08.9には、以下を含むすべての最新のセキュリティ修正が含まれています:

CVE-2019-19728:srunによる権限昇格を修正しました。この問題では、--uidが意図しない副作用をもたらす可能性があります(bsc#1159692)。

CVE-2019-19727:slurmdbd.confの権限を修正しました(bsc#1155784)。

pdshが以下に更新しました :slurmプラグインをビルドする際の代替SLURMバージョンのサポートを追加します。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-443=1

SUSE Linux Enterprise Module for HPC 15-SP1:zypper in -t patch SUSE-SLE-Module-HPC-15-SP1-2020-443=1

SUSE Linux Enterprise Module for HPC 15:zypper in -t patch SUSE-SLE-Module-HPC-15-2020-443=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1018371

https://bugzilla.suse.com/show_bug.cgi?id=1065697

https://bugzilla.suse.com/show_bug.cgi?id=1085240

https://bugzilla.suse.com/show_bug.cgi?id=1095508

https://bugzilla.suse.com/show_bug.cgi?id=1123304

https://bugzilla.suse.com/show_bug.cgi?id=1140709

https://bugzilla.suse.com/show_bug.cgi?id=1155784

https://bugzilla.suse.com/show_bug.cgi?id=1158709

https://bugzilla.suse.com/show_bug.cgi?id=1158798

https://bugzilla.suse.com/show_bug.cgi?id=1159692

https://www.suse.com/security/cve/CVE-2016-10030/

https://www.suse.com/security/cve/CVE-2017-15566/

https://www.suse.com/security/cve/CVE-2018-10995/

https://www.suse.com/security/cve/CVE-2018-7033/

https://www.suse.com/security/cve/CVE-2019-12838/

https://www.suse.com/security/cve/CVE-2019-19727/

https://www.suse.com/security/cve/CVE-2019-19728/

https://www.suse.com/security/cve/CVE-2019-6438/

http://www.nessus.org/u?f5e4d795

プラグインの詳細

深刻度: High

ID: 134036

ファイル名: suse_SU-2020-0443-1.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2020/2/25

更新日: 2020/2/27

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2016-10030

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.6

Temporal Score: 5.6

ベクトル: AV:N/AC:H/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.1

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libpmi0_18_08, p-cpe:/a:novell:suse_linux:libpmi0_18_08-debuginfo, p-cpe:/a:novell:suse_linux:libslurm33, p-cpe:/a:novell:suse_linux:libslurm33-debuginfo, p-cpe:/a:novell:suse_linux:pdsh, p-cpe:/a:novell:suse_linux:pdsh-debuginfo, p-cpe:/a:novell:suse_linux:pdsh-debugsource, p-cpe:/a:novell:suse_linux:pdsh-dshgroup, p-cpe:/a:novell:suse_linux:pdsh-dshgroup-debuginfo, p-cpe:/a:novell:suse_linux:pdsh-genders, p-cpe:/a:novell:suse_linux:pdsh-genders-debuginfo, p-cpe:/a:novell:suse_linux:pdsh-machines, p-cpe:/a:novell:suse_linux:pdsh-machines-debuginfo, p-cpe:/a:novell:suse_linux:pdsh-netgroup, p-cpe:/a:novell:suse_linux:pdsh-netgroup-debuginfo, p-cpe:/a:novell:suse_linux:pdsh-slurm, p-cpe:/a:novell:suse_linux:pdsh-slurm-debuginfo, p-cpe:/a:novell:suse_linux:pdsh-slurm_18_08, p-cpe:/a:novell:suse_linux:pdsh-slurm_18_08-debuginfo, p-cpe:/a:novell:suse_linux:perl-slurm_18_08, p-cpe:/a:novell:suse_linux:perl-slurm_18_08-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08, p-cpe:/a:novell:suse_linux:slurm_18_08-auth-none, p-cpe:/a:novell:suse_linux:slurm_18_08-auth-none-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-config, p-cpe:/a:novell:suse_linux:slurm_18_08-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-debugsource, p-cpe:/a:novell:suse_linux:slurm_18_08-devel, p-cpe:/a:novell:suse_linux:slurm_18_08-doc, p-cpe:/a:novell:suse_linux:slurm_18_08-lua, p-cpe:/a:novell:suse_linux:slurm_18_08-lua-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-munge, p-cpe:/a:novell:suse_linux:slurm_18_08-munge-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-node, p-cpe:/a:novell:suse_linux:slurm_18_08-node-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-pam_slurm, p-cpe:/a:novell:suse_linux:slurm_18_08-pam_slurm-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-plugins, p-cpe:/a:novell:suse_linux:slurm_18_08-plugins-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-slurmdbd, p-cpe:/a:novell:suse_linux:slurm_18_08-slurmdbd-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-sql, p-cpe:/a:novell:suse_linux:slurm_18_08-sql-debuginfo, p-cpe:/a:novell:suse_linux:slurm_18_08-torque, p-cpe:/a:novell:suse_linux:slurm_18_08-torque-debuginfo, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/2/24

脆弱性公開日: 2017/1/5

参照情報

CVE: CVE-2016-10030, CVE-2017-15566, CVE-2018-10995, CVE-2018-7033, CVE-2019-12838, CVE-2019-19727, CVE-2019-19728, CVE-2019-6438