PHP 7.3.x < 7.3.16の複数の脆弱性

high Nessus プラグイン ID 134944
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.3.16より前の7.3.xです。このため、以下の脆弱性の影響を受けます。

- EXIFでの初期化されていない値の使用につながる領域外読み取り(CVE-2020-7064)

- .rodataからオーバーフローした配列でスタック割り当てバッファが上書きされるスタックバッファオーバーフロー(CVE-2020-7065)

- 参照したURL内のnullバイト以降を通知なしで切り捨てるget_headers()認証されていないリモート攻撃者がこれを悪用し、機密情報を漏洩させたり、攻撃者が制御するデータをWebサーバーに予期せず処理させたりする可能性があります(CVE-2020-7066)。Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PHPバージョン7.3.16以降にアップグレードしてください。

関連情報

https://www.php.net/ChangeLog-7.php#7.3.16

プラグインの詳細

深刻度: High

ID: 134944

ファイル名: php_7_3_16.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/3/27

更新日: 2020/4/24

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2020-7065

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/3/19

脆弱性公開日: 2020/3/19

参照情報

CVE: CVE-2020-7064, CVE-2020-7065, CVE-2020-7066

IAVA: 2020-A-0117-S