Fedora 30:php(2020-ce5a2a7403)

high Nessus プラグイン ID 134962

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのFedoraホストにセキュリティ更新プログラムがありません。

説明

**PHPバージョン7.3.16**(2020年3月19日)

**コア:**

- バグphp#63206を修正しました(restore_error_handlerが以前のエラーマスクを復元しません)。(Mark Plmer氏)

**DOM:**

- バグphp#77569を修正しました:(DomImplementationの書き込みアクセス違反)。(Nikita、cmb)

- バグphp#79271を修正しました(DOMDocumentType::$childNodesはNULLです)。(cmb)

**Enchant:**

- バグphp#79311を修正しました(ビッグエンディアンアーキテクチャでenchant_dict_suggest()が失敗します)。(cmb)

**EXIF:**

- バグphp#79282を修正しました(exifのUse-of-uninitialized-value)。 (**CVE-2020-7064*)(Nikita氏)

**MBstring:**

- バグphp#79371を修正しました(php_unicode_tolower_fullのmb_strtolower(UTF-32LE):
スタックバッファオーバーフロー)。
(**CVE-2020-7065**)(cmb)

**MySQLi:**

- バグphp#64032を修正しました(mysqliによる異なるclient_versionの報告)。(cmb)

**PCRE:**

- バグphp#79188を修正しました(preg_replace/preg_replace_callbackおよびunicodeにおけるメモリ破損)。
(Nikita)

**PDO_ODBC:**

- バグphp#79038を修正しました(PDOStatement: : nextRowset()は列の値を漏洩します)。(cmb)

**リフレクション:**

- バグphp#79062を修正しました(heredocのデフォルト値を持つプロパティがgetDocCommentに対してfalseを返します)(Nikita)

**SQLite3:**

- バグphp#79294を修正しました(: : columnType()が、SQLType3Stmt: : reset()の後に失敗する可能性があります)。(cmb)

**Standard:**

- バグphp#79329を修正しました(get_headers()がNULLバイトの後に警告なしで切り捨てます)。(**CVE-2020-7066**)(cmb)

- バグphp#79254を修正しました (引数のないgetenv()の変更が表示されない)。(cmb)

- バグphp#79265を修正しました(httpリクエストに対してfopenを使用する際の、ホストヘッダーの不適切なインジェクション)。(Miguel Xavier Penha Neto氏)

注意:Tenable Network Securityは、前述の記述ブロックをFedora更新システムのWebサイトから直接抽出しています。
Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

影響を受けるphpパッケージを更新してください。

関連情報

https://bodhi.fedoraproject.org/updates/FEDORA-2020-ce5a2a7403

プラグインの詳細

深刻度: High

ID: 134962

ファイル名: fedora_2020-ce5a2a7403.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2020/3/27

更新日: 2020/4/3

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-7065

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:fedoraproject:fedora:php, cpe:/o:fedoraproject:fedora:30

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/3/26

脆弱性公開日: 2020/4/1

参照情報

CVE: CVE-2020-7064, CVE-2020-7065, CVE-2020-7066