openSUSE Security Update : qemu (openSUSE-2020-468)

medium Nessus プラグイン ID 135265

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

このqemuの更新では、次の問題を修正します:

- CVE-2020-7039:IRCとその他のプロトコルのエミュレート中のtcp_emu()ルーチン内のヒープバッファオーバーフローを修正しました(bsc#1161066)。

- CVE-2019-15034:PCI構成のスペース割り当てが不適切なことによる、hw/display/bochs-display.c内のバッファオーバーフローを修正しました(bsc#1166379)。

- CVE-2020-1711:ホスト上のQEMUプロセスの権限でリモートサービス拒否や任意のコード実行を引き起こす可能性のある、領域外ヒープバッファアクセスのiscsi_co_block_status()ルーチンを修正しました(bsc#1166240)。

- CVE-2019-6778:識別プロトコルをエミュレートし、メッセージデータをソケットバッファにコピーしている間の、tcp_emu()ルーチン内のヒープバッファオーバーフローを修正しました(bsc#1123156)。

- CVE-2020-8608:IRCとその他のプロトコルのエミュレート中のtcp_emu()ルーチン内のヒープバッファオーバーフローを修正しました(bsc#1163018)。

- CVE-2019-20382:ホストメモリを枯渇させ、サービス拒否を引き起こす可能性のある、VNCディスプレイドライバー内のメモリリークを修正しました(bsc#1165776)。

- ライブ移行エラーを修正しました(bsc#1154790)。

- KVMでVMを移行すると、features:ospkeの欠落エラーが発生する問題を修正しました(bsc#1162729)。

この更新はSUSEからインポートされました:SLE-15-SP1:更新プロジェクトを更新します。

ソリューション

影響を受けるQemuパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1123156

https://bugzilla.opensuse.org/show_bug.cgi?id=1154790

https://bugzilla.opensuse.org/show_bug.cgi?id=1161066

https://bugzilla.opensuse.org/show_bug.cgi?id=1162729

https://bugzilla.opensuse.org/show_bug.cgi?id=1163018

https://bugzilla.opensuse.org/show_bug.cgi?id=1165776

https://bugzilla.opensuse.org/show_bug.cgi?id=1166240

https://bugzilla.opensuse.org/show_bug.cgi?id=1166379

プラグインの詳細

深刻度: Medium

ID: 135265

ファイル名: openSUSE-2020-468.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2020/4/7

更新日: 2020/7/21

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-8608

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.6

Temporal Score: 4.9

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:novell:opensuse:15.1:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-arm:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-arm-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-curl:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-curl-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-rbd:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-rbd-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-extra:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-extra-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-guest-agent:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-guest-agent-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ipxe:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-kvm:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-lang:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-linux-user:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-linux-user-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-linux-user-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ppc:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ppc-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-s390:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-s390-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-seabios:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-sgabios:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-tools-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-vgabios:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-x86:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-x86-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-dmg:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-dmg-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-iscsi:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-iscsi-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-ssh:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-ssh-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ksm:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-gluster:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-gluster-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-alsa:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-alsa-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-oss:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-oss-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-pa:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-pa-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-sdl:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-audio-sdl-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-nfs:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-block-nfs-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ui-curses:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ui-curses-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ui-gtk:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ui-gtk-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ui-sdl:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:qemu-ui-sdl-debuginfo:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/4/6

脆弱性公開日: 2019/3/21

参照情報

CVE: CVE-2019-6778, CVE-2020-7039, CVE-2020-1711, CVE-2020-8608, CVE-2019-20382, CVE-2019-15034