RHEL 7: kernel-alt(RHSA-2020: 1493)

critical Nessus プラグイン ID 135685

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 7ホストにインストールされているパッケージは、RHSA-2020:1493アドバイザリに記載されている複数の脆弱性の影響を受けます。

- カーネル: drivers/net/wireless/marvell/mwifiex/sta_ioctl.cのmwifiex_process_country_ie()関数におけるヒープベースのバッファオーバーフロー(CVE-2019-14895)

- カーネル: marvell/mwifiex/tdls.cにおけるヒープオーバーフロー(CVE-2019-14901)

- カーネル: powerpc: ローカルユーザーが割り込みを介して他のユーザーのプロセスのベクトルレジスタを読み取る可能性がある(CVE-2019-15031)

- カーネル: drivers/net/wireless/ath/ath10k/usb.cのNULLポインターデリファレンスがクラッシュを引き起こす(CVE-2019-15099)

- kernel:__xfrm_policy_unlinkの領域外配列アクセス(CVE-2019-15666)

- kernel:cpu.cfs_quota_usが使用されるとき、攻撃者がnon-cpu-boundアプリケーションに対してサービス拒否を引き起こす可能性がある(CVE-2019-19922)

- カーネル: fs/proc/proc_sysctl.cのdrop_sysctl_table()におけるNULLポインターデリファレンス(CVE-2019-20054)

- カーネル: drivers/net/wireless/marvell/mwifiex/cfg80211.cのmwifiex_tm_cmdにおけるメモリリーク(CVE-2019-20095)

- カーネル: 必要な認証プロセスが完了する前にステーションにIAPPロケーションの更新を送信するようにAPをトリガーすると、DoSを引き起こす可能性がある(CVE-2019-5108)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/119.html

https://cwe.mitre.org/data/definitions/122.html

https://cwe.mitre.org/data/definitions/200.html

https://cwe.mitre.org/data/definitions/400.html

https://cwe.mitre.org/data/definitions/440.html

https://cwe.mitre.org/data/definitions/772.html

https://access.redhat.com/security/cve/CVE-2019-5108

https://access.redhat.com/security/cve/CVE-2019-14895

https://access.redhat.com/security/cve/CVE-2019-14901

https://access.redhat.com/security/cve/CVE-2019-15031

https://access.redhat.com/security/cve/CVE-2019-15099

https://access.redhat.com/security/cve/CVE-2019-15666

https://access.redhat.com/security/cve/CVE-2019-19922

https://access.redhat.com/security/cve/CVE-2019-20054

https://access.redhat.com/security/cve/CVE-2019-20095

https://access.redhat.com/errata/RHSA-2020:1493

https://bugzilla.redhat.com/1743560

https://bugzilla.redhat.com/1747334

https://bugzilla.redhat.com/1760063

https://bugzilla.redhat.com/1773519

https://bugzilla.redhat.com/1774870

https://bugzilla.redhat.com/1789927

https://bugzilla.redhat.com/1790063

https://bugzilla.redhat.com/1791954

https://bugzilla.redhat.com/1792512

プラグインの詳細

深刻度: Critical

ID: 135685

ファイル名: redhat-RHSA-2020-1493.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2020/4/16

更新日: 2021/7/21

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.7

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-14901

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:kernel, p-cpe:/a:redhat:enterprise_linux:kernel-abi-whitelists, p-cpe:/a:redhat:enterprise_linux:kernel-bootwrapper, p-cpe:/a:redhat:enterprise_linux:kernel-debug, p-cpe:/a:redhat:enterprise_linux:kernel-debug-devel, p-cpe:/a:redhat:enterprise_linux:kernel-devel, p-cpe:/a:redhat:enterprise_linux:kernel-headers, p-cpe:/a:redhat:enterprise_linux:kernel-kdump, p-cpe:/a:redhat:enterprise_linux:kernel-kdump-devel, p-cpe:/a:redhat:enterprise_linux:kernel-tools, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs-devel, p-cpe:/a:redhat:enterprise_linux:perf, p-cpe:/a:redhat:enterprise_linux:python-perf

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/4/16

脆弱性公開日: 2019/5/30

参照情報

CVE: CVE-2019-5108, CVE-2019-14895, CVE-2019-14901, CVE-2019-15031, CVE-2019-15099, CVE-2019-15666, CVE-2019-19922, CVE-2019-20054, CVE-2019-20095

RHSA: 2020:1493

CWE: 20, 119, 122, 200, 400, 440, 772