RHEL 6:Red Hat JBoss Webサーバー5.3リリース(重要)(RHSA-2020: 1520)

critical Nessus プラグイン ID 135773

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 6ホストにインストールされているパッケージは、RHSA-2020: 1520のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- tomcat:ローカルの権限昇格(CVE-2019-12418)

- tomcat:FORM認証時のセッション固定(CVE-2019-17563)

- tomcat:Transfer-Encodingヘッダーの処理での回帰により、HTTPリクエストのスマグリングが発生する可能性があります(CVE-2019-17569)

- tomcat:Transfer-Encodingヘッダーの不適切な処理により、HTTPリクエストのスマグリングが発生する可能性があります(CVE-2020-1935)

- tomcat:Apache TomcatのAJPファイル読み取り/インクルージョンの脆弱性(CVE-2020-1938)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/284.html

https://cwe.mitre.org/data/definitions/285.html

https://cwe.mitre.org/data/definitions/384.html

https://cwe.mitre.org/data/definitions/444.html

https://access.redhat.com/security/cve/CVE-2019-12418

https://access.redhat.com/security/cve/CVE-2019-17563

https://access.redhat.com/security/cve/CVE-2019-17569

https://access.redhat.com/security/cve/CVE-2020-1935

https://access.redhat.com/security/cve/CVE-2020-1938

https://access.redhat.com/errata/RHSA-2020:1520

https://bugzilla.redhat.com/1785699

https://bugzilla.redhat.com/1785711

https://bugzilla.redhat.com/1806398

https://bugzilla.redhat.com/1806835

https://bugzilla.redhat.com/1806849

プラグインの詳細

深刻度: Critical

ID: 135773

ファイル名: redhat-RHSA-2020-1520.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2020/4/21

更新日: 2022/3/8

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2020-1938

VPR

リスクファクター: Critical

スコア: 9.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-admin-webapps, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-docs-webapp, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-el-3.0-api, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-javadoc, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-jsp-2.3-api, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-lib, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-native, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-selinux, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-servlet-4.0-api, p-cpe:/a:redhat:enterprise_linux:jws5-tomcat-webapps

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/4/21

脆弱性公開日: 2019/12/23

CISAの既知の悪用日: 2022/3/17

参照情報

CVE: CVE-2019-12418, CVE-2019-17563, CVE-2019-17569, CVE-2020-1935, CVE-2020-1938

RHSA: 2020:1520

IAVA: 2020-A-0140, 2020-A-0328, 2020-A-0321

IAVB: 2020-B-0010-S

CWE: 284, 285, 384, 444