WordPressのプラグインLearnPress < 3.2.6.8 の複数の脆弱性

high Nessus プラグイン ID 136191

概要

リモートのWordPressアプリケーションには、複数の脆弱性の影響を受けるプラグインがインストールされています。

説明

リモートホストで実行されているWordPressアプリケーションには、3.2.6.8より前のバージョンの「LearnPress」プラグインがあり、以下に示す複数の脆弱性の影響を受けます。

- ユーザー入力の検証が不適切であるため、LP_Modal_Search_Itemsクラスの_get_itemsメソッドにSQLインジェクション(SQLi)の脆弱性があります。認証されたリモートの攻撃者がこれを悪用し、バックエンドデータベースでSQLクエリを挿入または操作することで、任意のデータを漏えいまたは操作する可能性があります。(CVE-2020-6010)

- リクエスト元ユーザーの権限がコードで検査されないので、learn_press_accept_become_a_teacher関数に権限昇格の脆弱性が存在します。認証されていないリモート攻撃者が/wpadmin/を介してこれを悪用し、アプリケーションへの「教師」アクセス権を得る可能性があります。(CVE-2020-11511)

Nessusはこれらの問題を悪用したことはありませんが、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

管理ダッシュボードを使用して、「LearnPress」プラグインをバージョン3.2.6.8以降に更新してください。

関連情報

http://www.nessus.org/u?b38b6cba

https://wordpress.org/plugins/learnpress/#developers

プラグインの詳細

深刻度: High

ID: 136191

ファイル名: wordpress_plugin_learnpress_3_2_6_8.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/5/1

更新日: 2022/5/13

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2020-11511

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

CVSS スコアのソース: CVE-2020-6010

脆弱性情報

CPE: cpe:/a:wordpress:wordpress

必要な KB アイテム: installed_sw/WordPress, www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/3/30

脆弱性公開日: 2020/3/30

参照情報

CVE: CVE-2020-6010, CVE-2020-11511