RHEL 6:java-1.8.0-ibm(RHSA-2020: 2239)

high Nessus プラグイン ID 136740

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 6ホストにインストールされているパッケージは、RHSA-2020: 2239アドバイザリに記載されている脆弱性の影響を受けます。

- OpenJDK:Kerberosプロキシ資格情報の不適切な処理(Kerberos、8220302)(CVE-2019-2949)

- OpenJDK:X.509証明書解析時のOID処理における過剰なメモリ消費(ライブラリ、8234037)(CVE-2020-2654)

- OpenJDK:RegExpScannerでの間違った正規表現の構文エラーチェック(スクリプティング、8223898)(CVE-2020-2754)

- OpenJDK:正規表現パーサーの空の文字列ノードの不適切な処理(スクリプティング、8223904)(CVE-2020-2755)

- OpenJDK:逆シリアル化中の初期化されていないクラス記述子への参照の不適切な処理(シリアル化、8224541)(CVE-2020-2756)

- OpenJDK:ObjectStreamClassでの捕捉されないInstantiationError例外(シリアル化、8224549)(CVE-2020-2757)

- OpenJDK:新しい接続に対する単一のTLSセッションの再利用(JSSE、8234408)(CVE-2020-2781)

- OpenJDK:HttpServerのHTTPヘッダーへのCRLFインジェクション(Lightweight HTTP Server、8234825)(CVE-2020-2800)

- OpenJDK:NIOバッファでの不適切な境界チェック(ライブラリ、8234841)(CVE-2020-2803)

- OpenJDK:MethodType.readObject()での不適切なタイプチェック(ライブラリ、8235274)(CVE-2020-2805)

- OpenJDK:Scannerの正規表現DoS(同時実行性、8236201)(CVE-2020-2830)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/113.html

https://cwe.mitre.org/data/definitions/119.html

https://cwe.mitre.org/data/definitions/185.html

https://cwe.mitre.org/data/definitions/248.html

https://cwe.mitre.org/data/definitions/400.html

https://cwe.mitre.org/data/definitions/522.html

https://cwe.mitre.org/data/definitions/770.html

https://access.redhat.com/security/cve/CVE-2019-2949

https://access.redhat.com/security/cve/CVE-2020-2654

https://access.redhat.com/security/cve/CVE-2020-2754

https://access.redhat.com/security/cve/CVE-2020-2755

https://access.redhat.com/security/cve/CVE-2020-2756

https://access.redhat.com/security/cve/CVE-2020-2757

https://access.redhat.com/security/cve/CVE-2020-2781

https://access.redhat.com/security/cve/CVE-2020-2800

https://access.redhat.com/security/cve/CVE-2020-2803

https://access.redhat.com/security/cve/CVE-2020-2805

https://access.redhat.com/security/cve/CVE-2020-2830

https://access.redhat.com/errata/RHSA-2020:2239

https://bugzilla.redhat.com/1761594

https://bugzilla.redhat.com/1791217

https://bugzilla.redhat.com/1823199

https://bugzilla.redhat.com/1823200

https://bugzilla.redhat.com/1823215

https://bugzilla.redhat.com/1823216

https://bugzilla.redhat.com/1823527

https://bugzilla.redhat.com/1823542

https://bugzilla.redhat.com/1823694

https://bugzilla.redhat.com/1823844

https://bugzilla.redhat.com/1823960

プラグインの詳細

深刻度: High

ID: 136740

ファイル名: redhat-RHSA-2020-2239.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2020/5/20

更新日: 2022/5/13

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.1

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2020-2800

CVSS v3

リスクファクター: High

Base Score: 8.3

Temporal Score: 7.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2020-2805

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:rhel_eus:6.0, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-demo, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-devel, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-jdbc, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-plugin, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-ibm-src

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/5/20

脆弱性公開日: 2019/10/15

参照情報

CVE: CVE-2019-2949, CVE-2020-2654, CVE-2020-2754, CVE-2020-2755, CVE-2020-2756, CVE-2020-2757, CVE-2020-2781, CVE-2020-2800, CVE-2020-2803, CVE-2020-2805, CVE-2020-2830

RHSA: 2020:2239

IAVA: 2019-A-0385

CWE: 20, 113, 119, 185, 248, 400, 522, 770