Scientific Linux セキュリティ更新: SL7.x x86_64のfreerdp(20201001)

medium Nessus プラグイン ID 141720

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのScientific Linuxホストに1つ以上のセキュリティ更新プログラムがありません。

説明

セキュリティ修正プログラム:

- freerdp: cliprdr_server_receive_capabilitiesでの領域外読み取り(CVE-2020-11018)

- freerdp: usbリダイレクトチャネルにおける領域外読み取り/書き込み(CVE-2020-11039)

- freerdp: update_read_icon_info関数での領域外読み取り(CVE-2020-11042)

- freerdp: autodetect_recv_bandwidth_measure_results関数における領域外読み取り(CVE-2020-11047)

- freerdp: winpr/libwinpr/sspi/NTLM/ntlm_message.cのntlm_read_ChallengeMessageにおける領域外読み取り。
(CVE-2020-13396)

- freerdp: libfreerdp/core/security.cのsecurity_fips_decryptにおける領域外読み取り(CVE-2020-13397)

- freerdp: update_recvでの領域外読み取りがクラッシュにつながる可能性があります(CVE-2020-11019)

- freerdp: VIDEOチャネルの整数オーバーフロー(CVE-2020-11038)

- freerdp: clear_decompress_subcode_rlexにおける領域外アクセス(CVE-2020-11040)

- freerdp: rdpsnd_recv_wave2_pduにおける配列オフセットの未チェックの読み取り(CVE-2020-11041)

- freerdp: rfx_process_message_tilesetにおける領域外読み取り(CVE-2020-11043)

- freerdp: update_read_cache_bitmap_v3_order関数における二重解放(CVE-2020-11044)

- freerdp: update_read_bitmap_data関数における領域外読み取り(CVE-2020-11045)

- freerdp: update_read_synchronize関数での領域外検索が、領域外読み取りを引き起こす可能性があります(CVE-2020-11046)

- freerdp: 領域外読み取りにより、セッションが中止される可能性があります(CVE-2020-11048)

- freerdp: クライアントメモリの領域外読み取りがプロトコルパーサーに渡されます(CVE-2020-11049)

- freerdp: rdp_read_font_capability_setのストリーム領域外検索が、領域外読み取りを発生させる可能性があります(CVE-2020-11058)

- freerdp: cliprdr_read_format_list関数における領域外読み取り(CVE-2020-11085)

- freerdp: ntlm_read_ntlm_v2_client_challenge関数における領域外読み取り(CVE-2020-11086)

- freerdp: ntlm_read_AuthenticateMessageにおける領域外読み取り(CVE-2020-11087)

- freerdp: ntlm_read_NegotiateMessageにおける領域外読み取り(CVE-2020-11088)

- freerdp: irp関数における領域外読み取り(CVE-2020-11089)

- freerdp: gdi.cにおける領域外読み取り(CVE-2020-11522)

- freerdp: bitmap.cにおける領域外読み取り(CVE-2020-11525)

- freerdp: update_recv_secondary_orderにおける領域外ストリームポインターにより、後に領域外読み取りが発生する可能性があります(CVE-2020-11526)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?aa03362d

プラグインの詳細

深刻度: Medium

ID: 141720

ファイル名: sl_20201001_freerdp_on_SL7_x.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2020/10/21

更新日: 2020/10/23

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-11522

VPR

リスクファクター: Medium

スコア: 5.2

CVSS v2

リスクファクター: Medium

Base Score: 6.4

Temporal Score: 4.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 5.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:fermilab:scientific_linux:freerdp, p-cpe:/a:fermilab:scientific_linux:freerdp-debuginfo, p-cpe:/a:fermilab:scientific_linux:freerdp-devel, p-cpe:/a:fermilab:scientific_linux:freerdp-libs, p-cpe:/a:fermilab:scientific_linux:libwinpr, p-cpe:/a:fermilab:scientific_linux:libwinpr-devel, x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/10/1

脆弱性公開日: 2020/5/7

参照情報

CVE: CVE-2020-11018, CVE-2020-11019, CVE-2020-11038, CVE-2020-11039, CVE-2020-11040, CVE-2020-11041, CVE-2020-11042, CVE-2020-11043, CVE-2020-11044, CVE-2020-11045, CVE-2020-11046, CVE-2020-11047, CVE-2020-11048, CVE-2020-11049, CVE-2020-11058, CVE-2020-11085, CVE-2020-11086, CVE-2020-11087, CVE-2020-11088, CVE-2020-11089, CVE-2020-11522, CVE-2020-11525, CVE-2020-11526, CVE-2020-13396, CVE-2020-13397