Scientific Linux セキュリティ更新: SL7.x i686/x86_64のqt(2020:5021)

medium Nessus プラグイン ID 142820
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのScientific Linuxホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのScientific Linux 7ホストには、RHSA-2020: 5021-1アドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- qt:gui/image/qxbmhandler.cppのread_xbm_bodyにおけるバッファオーバーリード(CVE-2020-17507)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://www.scientificlinux.org/category/sl-errata/slsa-20205021-1

プラグインの詳細

深刻度: Medium

ID: 142820

ファイル名: sl_20201110_qt_on_SL7_x.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2020/11/12

更新日: 2020/11/24

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-17507

VPR

リスクファクター: Low

スコア: 1.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:fermilab:scientific_linux, p-cpe:/a:fermilab:scientific_linux:qt, p-cpe:/a:fermilab:scientific_linux:qt-assistant, p-cpe:/a:fermilab:scientific_linux:qt-config, p-cpe:/a:fermilab:scientific_linux:qt-debuginfo, p-cpe:/a:fermilab:scientific_linux:qt-demos, p-cpe:/a:fermilab:scientific_linux:qt-devel, p-cpe:/a:fermilab:scientific_linux:qt-devel-private, p-cpe:/a:fermilab:scientific_linux:qt-doc, p-cpe:/a:fermilab:scientific_linux:qt-examples, p-cpe:/a:fermilab:scientific_linux:qt-mysql, p-cpe:/a:fermilab:scientific_linux:qt-odbc, p-cpe:/a:fermilab:scientific_linux:qt-postgresql, p-cpe:/a:fermilab:scientific_linux:qt-qdbusviewer, p-cpe:/a:fermilab:scientific_linux:qt-qvfb, p-cpe:/a:fermilab:scientific_linux:qt-x11, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-common, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-debuginfo, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-devel, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-doc, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-examples, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-gui, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-mysql, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-odbc, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-postgresql, p-cpe:/a:fermilab:scientific_linux:qt5-qtbase-static, p-cpe:/a:fermilab:scientific_linux:qt5-rpm-macros

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/11/10

脆弱性公開日: 2020/8/12

参照情報

CVE: CVE-2020-17507