phpMyAdmin 4.0.x < 4.0.10.10 / 4.2.x < 4.2.13.3 / 4.3.x < 4.3.13.1 / 4.4.x < 4.4.6.1の複数の脆弱性(PMASA-2015-2、PMASA-2015-3)

medium Nessus プラグイン ID 143273
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPアプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートの Web サーバーでホストされている phpMyAdmin アプリケーションは、4.0.10.10 より前の 4.0.x、4.2.13.3 より前の 4.2.x、4.3.13.1 より前の 4.3.x、4.4.6.1 より前の 4.4.x です。したがって、複数の脆弱性の影響を受けます。

4.0.10.10より前の4.0.x、4.2.13.3より前の4.2.x、4.3.13.1より前の4.3.x、および4.4.6.1より前の4.4.xのphpMyAdminのセットアッププロセスにおける複数のクロスサイトリクエスト偽造(XSRF)の脆弱性のため、リモートの攻撃者が管理者の認証をハイジャックし、構成ファイルの変更をリクエストすることが可能です。
(CVE-2015-3902)

- 4.0.10.10より前の4.0.x、4.2.13.3より前の4.2.x、 4.3.13.1より前の4.3.x、および4.4.6.1より前の4.4.xのphpMyAdminにおけるlibraries/Config.class.phpは、SSLを介したGitHub API呼び出しのX.509証明書検証を無効にするため、中間攻撃者がサーバーを偽装し、細工された証明書を介して機密情報を取得する子著が可能です。(CVE-2015-3903)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdminバージョン4.0.10.10/4.2.13.3/4.3.13.1/4.4.6.1以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2015-2/

https://www.phpmyadmin.net/security/PMASA-2015-3/

プラグインの詳細

深刻度: Medium

ID: 143273

ファイル名: phpmyadmin_pmasa_4_4_6_1.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/11/27

更新日: 2020/12/1

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2015-3902

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.3

Temporal Score: 5.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/5/13

脆弱性公開日: 2015/5/13

参照情報

CVE: CVE-2015-3902, CVE-2015-3903

BID: 74657, 74660

CWE: 295, 352, 661