Drupal 7.x < 7.75 / 8.x < 8.8.12 / 8.9.x < 8.9.10 / 9.0.x < 9.0.9の複数の脆弱性(SA-CORE-2020-013)

high Nessus プラグイン ID 143274
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPアプリケーションは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートのWebサーバーで実行されているDrupalのインスタンスは、7.75より前の7.x、8.8.12より前の8.x、8.9.10より前の8.9.x、または9.0.9より前の9.0.xです。そのため、以下の複数の脆弱性の影響を受けます。

- 1.4.10までのArchive_Tarでは、phar: はブロックされますが、PHAR: はブロックされないため、非シリアル化攻撃が可能です。(CVE-2020-28948)

- 1.4.10までのArchive_Tarでは、phar攻撃に対処するためだけに://ファイル名がサニタイズされるため、他のストリームラッパー攻撃(ファイルを上書きするfile://など)が依然として成功します。(CVE-2020-28949)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Drupalバージョン7.75/8.8.12/8.9.10/9.0.9以降にアップグレードしてください。

関連情報

https://www.drupal.org/sa-core-2020-013

https://www.drupal.org/node/1173280

https://www.drupal.org/project/drupal/releases/7.75

https://www.drupal.org/project/drupal/releases/8.8.12

https://www.drupal.org/project/drupal/releases/8.9.10

https://www.drupal.org/project/drupal/releases/9.0.9

プラグインの詳細

深刻度: High

ID: 143274

ファイル名: drupal_9_0_9.nasl

バージョン: 1.8

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/11/27

更新日: 2021/4/30

依存関係: drupal_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2020-28949

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.6

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:F/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7.2

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:drupal:drupal

必要な KB アイテム: installed_sw/Drupal, Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/11/25

脆弱性公開日: 2020/11/19

エクスプロイト可能

Metasploit (PEAR Archive_Tar 1.4.10 Arbitrary File Write)

参照情報

CVE: CVE-2020-28948, CVE-2020-28949

IAVA: 2020-A-0545-S