phpMyAdmin 4.0.0 < 4.0.10.17 / 4.4.0 < 4.4.15.8 / 4.6.0 < 4.6.4の複数の脆弱性

critical Nessus プラグイン ID 143282
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPアプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートのWebサーバーでホストされているphpMyAdminアプリケーションは、4.0.10.17より前の 4.0.x、4.4.15.8より前の4.4.x、および4.6.4より前の4.6.xです。したがって、複数の脆弱性の影響を受けます。

- phpMyAdmin内のcookieの暗号化に問題が見つかりました。ユーザー名/パスワードの復号化が、パディングオラクル攻撃に脆弱です。このため、ユーザーのブラウザcookieファイルにアクセスできる攻撃者が、ユーザー名とパスワードを解読できる可能性があります。また、phpMyAdmin cookieに保存されるユーザー名とパスワードをハッシュするために同じ初期化ベクトル(IV)が使用されます。ユーザーがユーザー名と同じパスワードを設定している場合、ブラウザcookieを調べる攻撃者はそれらが同じであることを確認できますが、まだハッシュされているためcookieからこれらの値を直接デコードできません。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6606)

- phpMyAdminにXSSの問題が見つかりました。これは、次のものに影響します。Zoom検索(特別に細工された列のコンテンツが、XSS攻撃を発生させるために使用される可能性があります)、GISエディター(グラフィカルGISエディターの特定のフィールドが適切にエスケープされておらず、XSS攻撃を発生させるために使用される可能性があります)、リレーションビュー、Transformations:
Formatted、Imagelink、JPEG: Upload、RegexValidation、JPEG inline、PNG inline、変換ラッパー、
XMLエクスポート、 MediaWikiエクスポート、デザイナー、MySQLサーバーが特別に細工されたlog_binディレクティブで実行されている場合、 Databaseタブ、レプリケーション機能、およびデータベース検索に影響します。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6607)

- phpMyAdminにXSSの問題が見つかりました。これは、データベース権限チェックおよびパーティション分割の削除機能に影響します。特別に細工されたデータベース名により、XSS 攻撃が発生する可能性があります。すべて4.6.xバージョン(4.6.4より前)に影響します。(CVE-2016-6608)

- phpMyAdminに問題が見つかりました。特別に細工されたデータベース名を利用して、配列エクスポート機能を通じて任意の PHP コマンドを実行される可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6609)

- phpMyAdminにフルパス漏洩の脆弱性が見つかりました。ユーザーが、エクスポートメカニズムで特別なエラーを発生し、ディスクのphpMyAdminのフルパスを発見する可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6610)

- phpMyAdminに問題が見つかりました。エクスポート機能を使ってSQLインジェクション攻撃を発生させるために、特別に細工された細工されたデータベースおよび/またはテーブル名が使用される可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6611)

- phpMyAdminに問題が見つかりました。ユーザーが LOAD LOCAL INFILE 機能を悪用して、サーバーのファイルをデータベースシステムに露出させる可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6612)

- phpMyAdminに問題が見つかりました。ユーザーが、phpMyAdminは読み取りを許可されているがユーザーは許可されていないファイルに対するシンボリックリンクをディスクで特別に細工する可能性があります。その後phpMyAdminがこれをそのユーザーに露出します。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6613)

- phpMyAdmiに、SaveDirおよびUploadDir機能の%uユーザー名置換機能に関わる問題が見つかりました。ユーザー名の置換が構成されている場合、特別に細工されたユーザー名を利用して制限を回避し、ファイルシステムのトラバーサルが実行される可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6614)

- phpMyAdminにXSSの問題が見つかりました。これは、ナビゲーションペインおよびデータベース/テーブル非表示機能(特別に細工されたデータベース名が、XSS攻撃を発生させるために使用される可能性があります)、トラッキング機能(特別に細工されたクエリが、XSS攻撃を発生させるために使用される可能性があります)、およびGIS可視化機能に影響します。すべての4.6.xバージョン(4.6.4より前)、および4.4.xバージョン(4.4.15.8より前)が影響を受けます。(CVE-2016-6615)

- phpMyAdminに問題が見つかりました。ユーザーグループとデザイナー機能において、ユーザーがコントロールユーザーのアカウントに対するSQLインジェクション攻撃を実行する可能性があります。すべての4.6.xバージョン(4.6.4より前)、および4.4.xバージョン(4.4.15.8より前)が影響を受けます。(CVE-2016-6616)

- phpMyAdminに問題が見つかりました。エクスポート機能を使ってSQLインジェクション攻撃を発生させるために、特別に細工された細工されたデータベースおよび/またはテーブル名が使用される可能性があります。すべて4.6.xバージョン(4.6.4より前)に影響します。(CVE-2016-6617)

- phpMyAdminに問題が見つかりました。変換機能を使って、ユーザーはサーバーに対するサービス拒否(DoS)攻撃を発生させることができます。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6618)

- phpMyAdminに問題が見つかりました。ユーザーインターフェイス設定機能において、ユーザーがコントロールユーザーのアカウントに対するSQLインジェクション攻撃を実行する可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6619)

- phpMyAdminに問題が見つかりました。一部のデータが、有効なシリアル化データであると検証されることなくPHP unserialize()関数に渡されます。オブジェクトのインスタンス化および自動ロードとの相互作用のため、シリアル化を解除するとコードが実行される可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6620)

- phpMyAdminに問題が見つかりました。認証されていないユーザーが、phpMyAdminが$cfg['AllowArbitraryServer']=trueで実行しているときに永続的な接続を強制することでサービス拒否(DoS)攻撃を仕掛けることができます。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6622)

- phpMyAdminに問題が見つかりました。承認されたユーザーが、大きな値をループに渡すことで、サーバーに対するサービス拒否(DoS)攻撃を仕掛ける可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6623)

- phpMyAdminに、IPベースの認証ルールの不適切な実施に関連する問題が見つかりました。
phpMyAdmin がプロキシサーバー環境で IPv6 で使用されており、プロキシサーバーは許可された範囲にいるが攻撃側のコンピューターは許可されていない場合、この脆弱性により、攻撃側のコンピューターが IP ルールにかかわらず接続できる可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6624)

- phpMyAdminに問題が見つかりました。攻撃者は、ユーザーがphpMyAdminにログインしているかどうかを確認できます。ユーザーのセッション、ユーザー名、パスワードが、この脆弱性により危険にさらされていません。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6625)

- phpMyAdminに問題が見つかりました。攻撃者は、ユーザーを悪意のあるWebページにリダイレクトする可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6626)

- phpMyAdminに問題が見つかりました。攻撃者は、url.phpファイルを使ってphpMyAdminホストの場所を特定できます。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6627)

- phpMyAdminに問題が見つかりました。攻撃者は、特別に細工された悪意のあるSVGファイルをユーザーにダウンロードさせる可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6628)

- phpMyAdminに、$cfg['ArbitraryServerRegexp']構成ディレクティブに関する問題が見つかりました。
攻撃者が、ArbitraryServerRegexp が定義するサーバーをバイパスする方法で、特定のクッキーの値を再利用する可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6629)

- phpMyAdminに問題が見つかりました。認証されたユーザーが、パスワード変更ダイアログで非常に長いパスワードを入力することで、サービス拒否(DoS)攻撃を仕掛ける可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6630)

- phpMyAdminに問題が見つかりました。phpMyAdminがCGIアプリケーションとして実行されているとき、ユーザーはサーバーに対してリモートコードの実行の攻撃を実行できる可能性があります。特定のサーバー構成で、ユーザーがクエリ文字列を渡す可能性があります。これは、generator_plugin.sh ファイルにより、コマンドライン引数として実行されます。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6631)

- phpMyAdminに問題が見つかりました。特定の状況で、phpMyAdminがESRIファイルのインポート中に一時ファイルを削除しない可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。(CVE-2016-6632)

- phpMyAdminに問題が見つかりました。phpMyAdminを使用して、dbase拡張で実行されている特定のPHPインストールに対するリモートコード実行の攻撃が引き起こされる可能性があります。すべての4.6.xバージョン(4.6.4より前)、4.4.xバージョン(4.4.15.8より前)、および4.0.xバージョン(4.0.10.17より前)が影響を受けます。
(CVE-2016-6633)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdmin バージョン 4.0.10.17 / 4.4.15.8 / 4.6.4 以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2016-29/

https://www.phpmyadmin.net/security/PMASA-2016-30/

https://www.phpmyadmin.net/security/PMASA-2016-31/

https://www.phpmyadmin.net/security/PMASA-2016-32/

https://www.phpmyadmin.net/security/PMASA-2016-33/

https://www.phpmyadmin.net/security/PMASA-2016-34/

https://www.phpmyadmin.net/security/PMASA-2016-35/

https://www.phpmyadmin.net/security/PMASA-2016-36/

https://www.phpmyadmin.net/security/PMASA-2016-37/

https://www.phpmyadmin.net/security/PMASA-2016-38/

https://www.phpmyadmin.net/security/PMASA-2016-39/

https://www.phpmyadmin.net/security/PMASA-2016-40/

https://www.phpmyadmin.net/security/PMASA-2016-41/

https://www.phpmyadmin.net/security/PMASA-2016-42/

https://www.phpmyadmin.net/security/PMASA-2016-43/

https://www.phpmyadmin.net/security/PMASA-2016-45/

https://www.phpmyadmin.net/security/PMASA-2016-46/

https://www.phpmyadmin.net/security/PMASA-2016-47/

https://www.phpmyadmin.net/security/PMASA-2016-48/

https://www.phpmyadmin.net/security/PMASA-2016-49/

https://www.phpmyadmin.net/security/PMASA-2016-50/

https://www.phpmyadmin.net/security/PMASA-2016-51/

https://www.phpmyadmin.net/security/PMASA-2016-52/

https://www.phpmyadmin.net/security/PMASA-2016-53/

https://www.phpmyadmin.net/security/PMASA-2016-54/

https://www.phpmyadmin.net/security/PMASA-2016-55/

https://www.phpmyadmin.net/security/PMASA-2016-56/

プラグインの詳細

深刻度: Critical

ID: 143282

ファイル名: phpmyadmin_pmasa_4_6_4.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/11/30

更新日: 2020/12/1

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2016-6629

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/8/16

脆弱性公開日: 2016/7/7

参照情報

CVE: CVE-2016-6606, CVE-2016-6607, CVE-2016-6608, CVE-2016-6609, CVE-2016-6610, CVE-2016-6611, CVE-2016-6612, CVE-2016-6613, CVE-2016-6614, CVE-2016-6615, CVE-2016-6616, CVE-2016-6617, CVE-2016-6618, CVE-2016-6619, CVE-2016-6620, CVE-2016-6622, CVE-2016-6623, CVE-2016-6624, CVE-2016-6625, CVE-2016-6626, CVE-2016-6627, CVE-2016-6628, CVE-2016-6629, CVE-2016-6630, CVE-2016-6631, CVE-2016-6632, CVE-2016-6633

BID: 92489, 92490, 92491, 92492, 92493, 92494, 92496, 92497, 92500, 92501, 93257, 93258, 94112, 94113, 94114, 94115, 94117, 94118, 94366, 95041, 95042, 95044, 95047, 95048, 95049, 95052, 95055

CWE: 661