Joomla 1.7.x < 3.9.23 複数の脆弱性(5828-joomla-3-9-23)

critical Nessus プラグイン ID 143380
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPアプリケーションは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートのWebサーバーで実行されているJoomla!のインスタンスは3.9.23より前の1.7.xです。したがって、複数の脆弱性の影響を受けます。

- com_finderの自動提案機能が、対応する用語のアクセスレベルを考慮していませんでした。

- グローバル構成ページがHTML出力からシークレットを削除せず、現在の値を漏洩させます。

- mod_random_imageのフォルダーパラメーターが入力を検証せず、パストラバーサルの脆弱性が発生します。

- フィルターのブラックリスト構成が不適切なため、バックエンドユーザーリストにSQLインジェクションの脆弱性が存在します。

- ユーザー名の不適切な処理により、バックエンドログインページでユーザー列挙攻撃のベクトルが引き起こされます。

- com_privacyのemailexport機能にトークンチェックが含まれないため、CSRFの脆弱性が発生します。

- ACLルールセットを処理する際に入力検証がなされないため、書き込みACL違反が引き起こされる可能性があります。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Joomla!をバージョン3.9.23以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?6b1cd937

http://www.nessus.org/u?402c1f24

http://www.nessus.org/u?d1499a20

http://www.nessus.org/u?f95e7c16

http://www.nessus.org/u?999b82fe

http://www.nessus.org/u?34e3f080

http://www.nessus.org/u?ba4d0911

http://www.nessus.org/u?0c15bad3

プラグインの詳細

深刻度: Critical

ID: 143380

ファイル名: joomla_3923.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/1

更新日: 2021/6/3

依存関係: joomla_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of the vendor advisory.

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

脆弱性情報

CPE: cpe:/a:joomla:joomla%5c%21

必要な KB アイテム: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

パッチ公開日: 2020/11/24

脆弱性公開日: 2020/11/24

参照情報

IAVA: 2020-A-0549-S