PHP 7.3.x < 7.3.25/7.4.x < 7.4.13の複数の脆弱性

medium Nessus プラグイン ID 143449
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます

説明

リモートホストにインストールされているPHPのバージョンは、7.3.25より前の7.3.x、または7.4.13より前の7.4.xです。したがって、それぞれの修正されたリリースの変更ログに示されているように、複数の脆弱性の影響を受けます。

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョンにのみ依存しています。

ソリューション

PHPバージョン7.3.25または7.4.13以降にアップグレードしてください。

関連情報

https://www.php.net/ChangeLog-7.php#7.3.25

https://www.php.net/ChangeLog-7.php#7.4.13

プラグインの詳細

深刻度: Medium

ID: 143449

ファイル名: php_7_4_13.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/3

更新日: 2021/6/3

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of vendor advisory.

CVSS v2

リスクファクター: Medium

Base Score: 6.8

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Medium

Base Score: 5.6

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/PHP

パッチ公開日: 2020/11/26

脆弱性公開日: 2020/11/26

参照情報

IAVA: 2020-A-0548-S