phpMyAdmin 4.0.x < 4.0.10.15 / 4.4.x < 4.4.15.5 / 4.5.x < 4.5.5.1の複数の脆弱性

medium Nessus プラグイン ID 143489
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPアプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートのWebサーバーでホストされているphpMyAdminアプリケーションは、4.0.10.15より前の 4.0.x、4.4.15.5より前の4.4.x、および4.5.5.1より前の4.5.xです。したがって、複数の脆弱性の影響を受けます。

- 4.5.5.1より前のphpMyAdmin4.5.xのSQLパーサーのlibraries / sql-parser / src / Utils /Error.phpのフォーマット関数におけるクロスサイトスクリプティング(XSS)の脆弱性により、リモート認証されたユーザーが、細工されたクエリを介して任意のWebスクリプトまたはHTMLを挿入することができます。(CVE-2016-2559)

-4.0.10.15より前の 4.0.x、4.4.15.5より前の4.4.x、4.5.5.1より前の4.5.xのphpMyAdmin内に複数のクロスサイトスクリプティング(XSS)の脆弱性があるため、リモートの攻撃者は(1)libraries /Config.class.phpに関連して細工されたホストHTTPヘッダーを介して; (2)file_echo.phpに関連して細工されたJSONデータを介して、(3)js /functions.jsに関連して細工されたSQLクエリを介して、(4)ユーザーアカウントページのlibraries / server_privileges.lib.phpへの初期パラメーターを介して、(5)ズーム検索ページのlibraries / controllers /TableSearchController.class.phpへのitパラメーターを介して、任意のWebスクリプトまたはHTMLを挿入できます。(CVE-2016-2560)

- 4.4.15.5より前のphpMyAdmin4.4.xおよび4.5.5.1より前のphpMyAdmin4.5.xの複数のクロスサイトスクリプティング(XSS)の脆弱性により、リモート認証されたユーザーは、(1)normalization.phpを介して、(2)データベースの正規化ページのjs / normalization.jsを介して、(3)データベース構造ページのtemplates / database / structure / sortable_header.phtmlを介して、(4)中央の列ページのdb_central_columns.phpへのposパラメーターを介して、任意のWebスクリプトまたはHTMLを挿入することができます。(CVE-2016-2561)

- 4.5.5.1より前のphpMyAdmin4.5.xのlibraries / Config.class.phpのcheckHTTP関数は、api.github.com SSLサーバーからのX.509証明書を検証しません。これにより、細工された証明書を介して、中間者攻撃者がこれらのサーバーをスプーフィングして機密情報を取得できます。 (CVE-2016-2562)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdmin バージョン 4.0.10.15 / 4.4.15.5 / 4.5.5.1 以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2016-10/

https://www.phpmyadmin.net/security/PMASA-2016-11/

https://www.phpmyadmin.net/security/PMASA-2016-12/

https://www.phpmyadmin.net/security/PMASA-2016-13/

プラグインの詳細

深刻度: Medium

ID: 143489

ファイル名: phpmyadmin_pmasa_4_5_5_1.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/7

更新日: 2020/12/8

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2016-2562

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.9

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/3/1

脆弱性公開日: 2016/3/1

参照情報

CVE: CVE-2016-2559, CVE-2016-2560, CVE-2016-2561, CVE-2016-2562

BID: 83704, 83711, 83717, 83718

CWE: 79, 295, 661