phpMyAdmin 4.0.x < 4.0.10.18 / 4.4.x < 4.4.15.9 / 4.6.x < 4.6.5の複数の脆弱性

critical Nessus プラグイン ID 143532
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPアプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートのWebサーバーでホストされているphpMyAdminアプリケーションは、4.0.10.18より前の 4.0.x、4.4.15.9より前の4.4.x、および4.6.5より前の4.6.xです。したがって、複数の脆弱性の影響を受けます。

- phpMyAdminに問題が見つかりました。ユーザーがクッキーの暗号化にblowfish_secretキーを指定しない場合、phpMyAdminはランタイムでそれを生成します。この値が作成される方法で弱いアルゴリズムが使用される場合、脆弱性が報告されました。これにより、攻撃者がユーザーのblowfish_secretを特定し、Cookieを復号する可能性があります。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9847)

-phpMyAdminで問題が発見されました。 phpinfo(phpinfo.php)は、HttpOnlyクッキーの値を含むPHP情報を表示します。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9848)

- phpMyAdminに問題が見つかりました。ユーザー名でNullバイトを使用することで、AllowRoot制限($cfg['Servers'] [$i] ['AllowRoot'])をバイパスし、ユーザー名のルールを拒否することが可能です。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9849)

- phpMyAdminに問題が見つかりました。一致するユーザー名の許可/拒否ルールが原因で、一定ではない実行時間のためにルールで誤った一致とユーザー名が検出される場合があります。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9850)

- phpMyAdminに問題が見つかりました。細工されたリクエストパラメーター値により、ログアウトタイムアウトをバイパスすることが可能です。すべての4.6.xバージョン(4.6.5より前)、および4.4.xバージョン(4.4.15.9より前)が影響を受けます。
(CVE-2016-9851)

- phpMyAdminに問題が見つかりました。phpMyAdmin の一部である何らかのスクリプトを予期されない方法で呼び出すことで、phpMyAdmin に、phpMyAdmin がインストールされているディレクトリのフルパスが含まれる PHP エラーメッセージを表示させることができます。エクスポート機能の実行タイムアウト中に、phpMyAdminのディレクトリのフルパスを含むエラーがエクスポートファイルに書き込まれます。すべての4.6.xバージョン(4.6.5より前)、および4.4.xバージョン(4.4.15.9より前)が影響を受けます。
このCVEはcurlラッパーの問題のためのものです。(CVE-2016-9852)

- phpMyAdminに問題が見つかりました。phpMyAdmin の一部である何らかのスクリプトを予期されない方法で呼び出すことで、phpMyAdmin に、phpMyAdmin がインストールされているディレクトリのフルパスが含まれる PHP エラーメッセージを表示させることができます。エクスポート機能の実行タイムアウト中に、phpMyAdminのディレクトリのフルパスを含むエラーがエクスポートファイルに書き込まれます。すべての4.6.xバージョン(4.6.5より前)、および4.4.xバージョン(4.4.15.9より前)が影響を受けます。
このCVEはcurlラッパーの問題のためのものです。(CVE-2016-9853)

- phpMyAdminに問題が見つかりました。phpMyAdmin の一部である何らかのスクリプトを予期されない方法で呼び出すことで、phpMyAdmin に、phpMyAdmin がインストールされているディレクトリのフルパスが含まれる PHP エラーメッセージを表示させることができます。エクスポート機能の実行タイムアウト中に、phpMyAdminのディレクトリのフルパスを含むエラーがエクスポートファイルに書き込まれます。すべての4.6.xバージョン(4.6.5より前)、および4.4.xバージョン(4.4.15.9より前)が影響を受けます。
このCVEはjson_decodeの問題のためのものです。 (CVE-2016-9854)

- phpMyAdminに問題が見つかりました。phpMyAdmin の一部である何らかのスクリプトを予期されない方法で呼び出すことで、phpMyAdmin に、phpMyAdmin がインストールされているディレクトリのフルパスが含まれる PHP エラーメッセージを表示させることができます。エクスポート機能の実行タイムアウト中に、phpMyAdminのディレクトリのフルパスを含むエラーがエクスポートファイルに書き込まれます。すべての4.6.xバージョン(4.6.5より前)、および4.4.xバージョン(4.4.15.9より前)が影響を受けます。
このCVEはPMA_shutdownDuringExport問題のためのものです。 (CVE-2016-9855)

-PMASA-2016-10のCVE-2016-2559に対する修正が不適切なため、phpMyAdminにXSSの問題が発見されました。
この問題は、競合状態を回避するためにハッシュのコピーを使用することで解決されています。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。
(CVE-2016-9856)

- phpMyAdminに問題が見つかりました。一部のJavaScript処理で使用される正規表現が弱いため、XSSが発生する可能性があります。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9857)

- phpMyAdminに問題が見つかりました。細工されたリクエストパラメーター値により、保存された検索機能でサービス拒否攻撃を開始することが可能です。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9858)

- phpMyAdminに問題が見つかりました。細工されたリクエストパラメーター値により、インポート機能でサービス拒否攻撃を開始することが可能です。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9859)

- phpMyAdminに問題が見つかりました。認証されていないユーザーが、phpMyAdminが $cfg['AllowArbitraryServer']=trueで実行されているときに、サービス拒否攻撃を実行することが可能です。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9860)

- phpMyAdminに問題が見つかりました。URLマッチングの制限により、URLホワイトリスト保護をバイパスすることが可能でした。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9861)

- phpMyAdminに問題が見つかりました。細工されたログインリクエストにより、ログインページにBBCodeを注入することが可能です。すべて4.6.xバージョン(4.6.5より前)に影響します。(CVE-2016-9862)

- phpMyAdminに問題が見つかりました。テーブルパーティショニング関数に対する非常に大きなリクエストにより、サービス拒否(DoS)攻撃を引き起こすことが可能です。すべての4.6.xバージョン(4.6.5以前)が影響を受けます。
(CVE-2016-9863)

- phpMyAdminに問題が見つかりました。細工されたユーザー名またはテーブル名を使用して、コントロールユーザーの権限で実行する追跡機能に、SQLステートメントを注入することが可能でした。これにより、構成ストレージデータベースのテーブルに読み書きアクセスができるようになり、さらにコントロールユーザーに必要な権限がある場合は、MySQLデータベースの一部のテーブルに読み取りアクセスが可能になります。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。
(CVE-2016-9864)

- phpMyAdminに問題が見つかりました。シリアル化された文字列解析のバグにより、PMA_safeUnserialize() 関数によって提供される保護がバイパスされる可能性がありました。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9865)

- phpMyAdminに問題が見つかりました。arg_separatorがデフォルト値と異なる場合、プリファレンスインポートアクションの返却URLからCSRFトークンが適切に削除されませんでした。すべての4.6.xバージョン(4.6.5より前)、4.4.xバージョン(4.4.15.9より前)、および4.0.xバージョン(4.0.10.18より前)が影響を受けます。(CVE-2016-9866)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdminバージョン 4.0.10.18 / 4.4.15.9 / 4.6.5 以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2016-58/

https://www.phpmyadmin.net/security/PMASA-2016-59/

https://www.phpmyadmin.net/security/PMASA-2016-60/

https://www.phpmyadmin.net/security/PMASA-2016-61/

https://www.phpmyadmin.net/security/PMASA-2016-62/

https://www.phpmyadmin.net/security/PMASA-2016-63/

https://www.phpmyadmin.net/security/PMASA-2016-64/

https://www.phpmyadmin.net/security/PMASA-2016-65/

https://www.phpmyadmin.net/security/PMASA-2016-66/

https://www.phpmyadmin.net/security/PMASA-2016-67/

https://www.phpmyadmin.net/security/PMASA-2016-68/

https://www.phpmyadmin.net/security/PMASA-2016-69/

https://www.phpmyadmin.net/security/PMASA-2016-70/

https://www.phpmyadmin.net/security/PMASA-2016-71/

プラグインの詳細

深刻度: Critical

ID: 143532

ファイル名: phpmyadmin_pmasa_4_6_5.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/7

更新日: 2020/12/21

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2016-9865

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/11/25

脆弱性公開日: 2016/11/25

参照情報

CVE: CVE-2016-9847, CVE-2016-9848, CVE-2016-9849, CVE-2016-9850, CVE-2016-9851, CVE-2016-9852, CVE-2016-9853, CVE-2016-9854, CVE-2016-9855, CVE-2016-9856, CVE-2016-9857, CVE-2016-9858, CVE-2016-9859, CVE-2016-9860, CVE-2016-9861, CVE-2016-9862, CVE-2016-9863, CVE-2016-9864, CVE-2016-9865, CVE-2016-9866

BID: 94521, 94523, 94524, 94525, 94526, 94527, 94528, 94529, 94530, 94531, 94533, 94534, 94535, 94536

CWE: 20, 89, 352, 400, 601, 661