SUSE SLES12セキュリティ更新プログラム:カーネル(SUSE-SU-2020:3715-1)

high Nessus プラグイン ID 143619

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

SUSE Linux Enterprise 12 SP5 Azureカーネルが更新され、さまざまなセキュリティとバグの修正が行われています。

以下のセキュリティバグが修正されました。

CVE-2020-15437:ローカルユーザーがサービス拒否を引き起こす可能性があったNULLポインターデリファレンスを修正しました(bsc#1179140)。

CVE-2020-27777:ユーザー空間からのRTASリクエストを制限します(bsc#1179107)。

CVE-2020-28974:特権情報を読み取るためにローカルの攻撃者によって使用されたり、カーネルのクラッシュを引き起こす可能性があった、fbconにおけるスラブ領域外書き込みを修正しました(bsc#1178589)。

CVE-2020-28915:カーネルメモリを読み取るためにローカルの攻撃者によって使用される可能性があった、fbconコードのバッファオーバーリードを修正しました(bsc#1178886)。

CVE-2020-8694:一部のIntel(R)プロセッサのアクセス制御が不十分なため、認証されたユーザーがローカルアクセスを介して情報漏洩を引き起こす可能性がありました(bsc#1170415)。

CVE-2020-25668:con_font_op()でのUse-After-Freeを修正しました(bsc#1178123)。

CVE-2020-25704:perf_event_parse_addr_filter()におけるメモリリークを修正しました(bsc#1178393)。

CVE-2020-25669:sunkbd_reinit()でのUse-After-Free読み取りを修正しました(bsc#1178182)。

更新パッケージには、セキュリティ関連以外の修正も含まれています。詳細については、アドバイザリを参照してください。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-3715=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1050549

https://bugzilla.suse.com/show_bug.cgi?id=1058115

https://bugzilla.suse.com/show_bug.cgi?id=1067665

https://bugzilla.suse.com/show_bug.cgi?id=1111666

https://bugzilla.suse.com/show_bug.cgi?id=1112178

https://bugzilla.suse.com/show_bug.cgi?id=1167030

https://bugzilla.suse.com/show_bug.cgi?id=1170139

https://bugzilla.suse.com/show_bug.cgi?id=1170415

https://bugzilla.suse.com/show_bug.cgi?id=1170446

https://bugzilla.suse.com/show_bug.cgi?id=1170630

https://bugzilla.suse.com/show_bug.cgi?id=1172542

https://bugzilla.suse.com/show_bug.cgi?id=1172873

https://bugzilla.suse.com/show_bug.cgi?id=1174726

https://bugzilla.suse.com/show_bug.cgi?id=1175306

https://bugzilla.suse.com/show_bug.cgi?id=1175916

https://bugzilla.suse.com/show_bug.cgi?id=1176109

https://bugzilla.suse.com/show_bug.cgi?id=1176855

https://bugzilla.suse.com/show_bug.cgi?id=1176907

https://bugzilla.suse.com/show_bug.cgi?id=1176983

https://bugzilla.suse.com/show_bug.cgi?id=1177304

https://bugzilla.suse.com/show_bug.cgi?id=1177397

https://bugzilla.suse.com/show_bug.cgi?id=1177703

https://bugzilla.suse.com/show_bug.cgi?id=1177805

https://bugzilla.suse.com/show_bug.cgi?id=1177808

https://bugzilla.suse.com/show_bug.cgi?id=1177809

https://bugzilla.suse.com/show_bug.cgi?id=1177819

https://bugzilla.suse.com/show_bug.cgi?id=1177820

https://bugzilla.suse.com/show_bug.cgi?id=1178123

https://bugzilla.suse.com/show_bug.cgi?id=1178182

https://bugzilla.suse.com/show_bug.cgi?id=1178393

https://bugzilla.suse.com/show_bug.cgi?id=1178589

https://bugzilla.suse.com/show_bug.cgi?id=1178591

https://bugzilla.suse.com/show_bug.cgi?id=1178607

https://bugzilla.suse.com/show_bug.cgi?id=1178635

https://bugzilla.suse.com/show_bug.cgi?id=1178669

https://bugzilla.suse.com/show_bug.cgi?id=1178686

https://bugzilla.suse.com/show_bug.cgi?id=1178700

https://bugzilla.suse.com/show_bug.cgi?id=1178765

https://bugzilla.suse.com/show_bug.cgi?id=1178838

https://bugzilla.suse.com/show_bug.cgi?id=1178853

https://bugzilla.suse.com/show_bug.cgi?id=1178854

https://bugzilla.suse.com/show_bug.cgi?id=1178878

https://bugzilla.suse.com/show_bug.cgi?id=1178886

https://bugzilla.suse.com/show_bug.cgi?id=1178897

https://bugzilla.suse.com/show_bug.cgi?id=1178940

https://bugzilla.suse.com/show_bug.cgi?id=1178962

https://bugzilla.suse.com/show_bug.cgi?id=1179107

https://bugzilla.suse.com/show_bug.cgi?id=1179140

https://bugzilla.suse.com/show_bug.cgi?id=1179211

https://bugzilla.suse.com/show_bug.cgi?id=1179213

https://bugzilla.suse.com/show_bug.cgi?id=1179259

https://bugzilla.suse.com/show_bug.cgi?id=1179424

https://bugzilla.suse.com/show_bug.cgi?id=1179426

https://bugzilla.suse.com/show_bug.cgi?id=1179427

https://bugzilla.suse.com/show_bug.cgi?id=927455

https://www.suse.com/security/cve/CVE-2020-15437/

https://www.suse.com/security/cve/CVE-2020-25668/

https://www.suse.com/security/cve/CVE-2020-25669/

https://www.suse.com/security/cve/CVE-2020-25704/

https://www.suse.com/security/cve/CVE-2020-27777/

https://www.suse.com/security/cve/CVE-2020-28915/

https://www.suse.com/security/cve/CVE-2020-28974/

https://www.suse.com/security/cve/CVE-2020-8694/

http://www.nessus.org/u?cde116d5

プラグインの詳細

深刻度: High

ID: 143619

ファイル名: suse_SU-2020-3715-1.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2020/12/9

更新日: 2022/5/11

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2020-27777

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2020-25669

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:kernel-azure, p-cpe:/a:novell:suse_linux:kernel-azure-base, p-cpe:/a:novell:suse_linux:kernel-azure-base-debuginfo, p-cpe:/a:novell:suse_linux:kernel-azure-debuginfo, p-cpe:/a:novell:suse_linux:kernel-azure-debugsource, p-cpe:/a:novell:suse_linux:kernel-azure-devel, p-cpe:/a:novell:suse_linux:kernel-syms-azure, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/12/8

脆弱性公開日: 2020/11/12

参照情報

CVE: CVE-2020-8694, CVE-2020-15437, CVE-2020-25668, CVE-2020-25669, CVE-2020-25704, CVE-2020-27777, CVE-2020-28915, CVE-2020-28974