SUSE SLES12セキュリティ更新プログラム:python36(SUSE-SU-2020:3563-1)

high Nessus プラグイン ID 143646

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

python36用のこの更新プログラムでは、以下の問題が修正されています:

次の修正を含む3.6.12に更新します:

_download_http_url()のディレクトリトラバーサルを修正しました(bsc#1176262 CVE-2019-20916)

httplib/http.clientにおけるHTTPリクエストメソッドによるCRLFインジェクションを修正しました(bsc#1177211 CVE-2020-26116)

特別に細工されたtarballで発生する可能性がある無限ループを修正しました(bsc#1174091 CVE-2019-20907)

urlopen()に渡されるURLのホスト部分を介したCRLFインジェクションを修正しました(bsc#1155094 CVE-2019-18348)

python2との競合を回避するために、アイドルアイコンの名前をidle3に変更しました(bsc#1165894)

SLE15とSLE12の間のわずかな互換性の変更(jsc#ECO-2799、jsc#SLE-13738、bsc#1179193)

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-3563=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1149955

https://bugzilla.suse.com/show_bug.cgi?id=1165894

https://bugzilla.suse.com/show_bug.cgi?id=1174091

https://bugzilla.suse.com/show_bug.cgi?id=1176262

https://bugzilla.suse.com/show_bug.cgi?id=1177211

https://www.suse.com/security/cve/CVE-2019-16056/

https://www.suse.com/security/cve/CVE-2019-20907/

https://www.suse.com/security/cve/CVE-2019-20916/

https://www.suse.com/security/cve/CVE-2019-5010/

https://www.suse.com/security/cve/CVE-2020-14422/

https://www.suse.com/security/cve/CVE-2020-26116/

https://www.suse.com/security/cve/CVE-2020-8492/

http://www.nessus.org/u?18acf836

プラグインの詳細

深刻度: High

ID: 143646

ファイル名: suse_SU-2020-3563-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2020/12/9

更新日: 2022/5/11

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2020-26116

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 6.4

Temporal Score: 4.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libpython3_6m1_0, p-cpe:/a:novell:suse_linux:libpython3_6m1_0-debuginfo, p-cpe:/a:novell:suse_linux:python36, p-cpe:/a:novell:suse_linux:python36-base, p-cpe:/a:novell:suse_linux:python36-base-debuginfo, p-cpe:/a:novell:suse_linux:python36-debuginfo, p-cpe:/a:novell:suse_linux:python36-debugsource, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/11/30

脆弱性公開日: 2019/9/6

参照情報

CVE: CVE-2019-5010, CVE-2019-16056, CVE-2019-18348, CVE-2019-20907, CVE-2019-20916, CVE-2020-8492, CVE-2020-14422, CVE-2020-26116