RHEL 8:- mariadb:10.3(RHSA-2020: 5654)

critical Nessus プラグイン ID 144548
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートのRedhat Enterprise Linux 8ホストにインストールされているパッケージは、RHSA-2020: 5654のアドバイザリ。

- mysql: InnoDBの詳細不明な脆弱性(CPU 2019年10月)(CVE-2019-2938)

- mysql: サーバー: オプティマイザーの詳細不明な脆弱性(CPU 2019年10月)(CVE-2019-2974)

-mariadb-connector-c: サーバーから受信したOKパケットのコンテンツの不適切な検証(CVE-2020-13249)

- mysql: サーバー: FTSの詳細不明な脆弱性(CPU 2020年10月)(CVE-2020-14765、CVE-2020-14789)

- mysql: InnoDBの詳細不明な脆弱性(CPU 2020年10月)(CVE-2020-14776)

- mysql: サーバー: ロックの詳細不明な脆弱性(CPU 2020年10月)(CVE-2020-14812)

- mariadb:mysql-wsrepでのコードインジェクションにつながる不十分なSSTメソッド名チェック(CVE-2020-15180)

- mysql: C APIの詳細不明な脆弱性(CPU 2020年1月)(CVE-2020-2574)

- mysql: C APIの詳細不明な脆弱性(CPU 2020年4月)(CVE-2020-2752)

- mysql: InnoDBの詳細不明な脆弱性(CPU 2020年4月)(CVE-2020-2760、CVE-2020-2814)

- mysql: サーバー: DMLの詳細不明な脆弱性(CPU 2020年4月)(CVE-2020-2780)

- mysql: サーバー: ストアドプロシージャの詳細不明な脆弱性(CPU 2020年4月)(CVE-2020-2812)

- mysql: InnoDBの詳細不明な脆弱性(CPU 2021年1月)(CVE-2021-2022)

- mysql: サーバー:パーサーの詳細不明の脆弱性(CPU 2021年4月)(CVE-2021-2144)

- mysql: InnoDBの詳細不明な脆弱性(CPU 2021年4月)(CVE-2021-2194)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/400.html

https://access.redhat.com/security/cve/CVE-2020-2780

https://access.redhat.com/security/cve/CVE-2020-2812

https://access.redhat.com/security/cve/CVE-2020-2814

https://access.redhat.com/security/cve/CVE-2020-2760

https://access.redhat.com/security/cve/CVE-2019-2938

https://access.redhat.com/security/cve/CVE-2019-2974

https://cwe.mitre.org/data/definitions/96.html

https://access.redhat.com/security/cve/CVE-2020-2574

https://access.redhat.com/security/cve/CVE-2020-2752

https://bugzilla.redhat.com/1764680

https://bugzilla.redhat.com/1764691

https://bugzilla.redhat.com/1798587

https://bugzilla.redhat.com/1830056

https://bugzilla.redhat.com/1830059

https://bugzilla.redhat.com/1830060

https://bugzilla.redhat.com/1830082

https://bugzilla.redhat.com/1835849

https://access.redhat.com/security/cve/CVE-2020-15180

https://bugzilla.redhat.com/1894919

https://access.redhat.com/security/cve/CVE-2020-13249

https://bugzilla.redhat.com/1839827

https://access.redhat.com/security/cve/CVE-2020-14765

https://access.redhat.com/security/cve/CVE-2020-14776

https://access.redhat.com/security/cve/CVE-2020-14789

https://access.redhat.com/security/cve/CVE-2020-14812

https://bugzilla.redhat.com/1890738

https://bugzilla.redhat.com/1890743

https://bugzilla.redhat.com/1890747

https://bugzilla.redhat.com/1890756

https://access.redhat.com/errata/RHSA-2020:5654

https://access.redhat.com/security/cve/CVE-2021-2144

https://bugzilla.redhat.com/1951749

https://access.redhat.com/security/cve/CVE-2021-2022

https://access.redhat.com/security/cve/CVE-2021-2194

https://bugzilla.redhat.com/1922389

https://bugzilla.redhat.com/1951764

プラグインの詳細

深刻度: Critical

ID: 144548

ファイル名: redhat-RHSA-2020-5654.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2020/12/22

更新日: 2021/10/12

依存関係: ssh_get_info.nasl, redhat_repos.nasl

リスク情報

CVSS スコアのソース: CVE-2020-15180

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9

Temporal Score: 7.8

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:redhat:rhel_aus:8.2:*:*:*:*:*:*:*, cpe:2.3:o:redhat:rhel_e4s:8.2:*:*:*:*:*:*:*, cpe:2.3:o:redhat:rhel_eus:8.2:*:*:*:*:*:*:*, cpe:2.3:o:redhat:rhel_tus:8.2:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-embedded:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-embedded-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-server:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-test:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:judy:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:galera:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-backup:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-common:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-errmsg:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-gssapi-server:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-oqgraph-engine:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-server-galera:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:mariadb-server-utils:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/12/22

脆弱性公開日: 2019/10/15

参照情報

CVE: CVE-2019-2938, CVE-2019-2974, CVE-2020-2574, CVE-2020-2752, CVE-2020-2760, CVE-2020-2780, CVE-2020-2812, CVE-2020-2814, CVE-2020-13249, CVE-2020-15180, CVE-2020-14765, CVE-2020-14789, CVE-2020-14776, CVE-2020-14812

CWE: 20, 400, 96

IAVA: 2020-A-0143, 2021-A-0038, 2020-A-0473-S, 2021-A-0193, 2019-A-0383-S, 2020-A-0021-S

RHSA: 2020:5654