phpMyAdmin 4.0.0 < 4.0.10.12 / 4.4.0 < 4.4.15.2 / 4.5.0 < 4.5.3.1 情報漏洩 (PMASA-2015-6)

medium Nessus プラグイン ID 144641
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、情報漏洩の脆弱性により影響を受ける PHP アプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートのWebサーバーでホストされているphpMyAdminアプリケーションは、4.0.10.12より前の 4.0.x、4.4.15.2より前の4.4.x、および4.5.3.1より前の4.5.xです。したがって、以下の情報漏洩の脆弱性の影響を受けます。

-4.0.10.12より前の 4.0.x、4.4.15.2より前の 4.4.x、および 4.5.3.1より前の4.5.xphpMyAdminでの libraries/config/messages.inc.phpにより、リモートの攻撃者が、細工されたリクエストを介して機密情報を取得することが可能になり、エラーメッセージにフルパスが表示されます。(CVE-2015-8669)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdminバージョン 4.0.10.12 / 4.4.15.2 / 4.5.3.1 以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2015-6/

プラグインの詳細

深刻度: Medium

ID: 144641

ファイル名: phpmyadmin_pmasa_2015_6.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/30

更新日: 2020/12/31

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2015-8669

VPR

リスクファクター: Low

スコア: 1.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2015/12/25

脆弱性公開日: 2015/12/25

参照情報

CVE: CVE-2015-8669

BID: 79691

CWE: 200, 661