phpMyAdmin 4.9.0 < 4.9.5 / 5.0.0 < 5.0.2 複数の脆弱性(PMASA-2020-2、PMASA-2020-3、PMASA-2020-4)

high Nessus プラグイン ID 144646
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPアプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートのWebサーバーでホストされているphpMyAdminアプリケーションは、4.9.5より前の4.9.xもしくは5.0.2より前の5.0.xです。したがって、複数の脆弱性の影響を受けます。

- phpMyAdminの4.9.5以前の4.x、5.0.2以前の5.xで、現在のユーザー名の取得にSQLインジェクションの脆弱性が見つかりました(libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.phpにあります)。サーバーへのアクセス権を持つ悪意のあるユーザーが細工されたユーザー名を作成し、被害者を騙して、そのユーザーアカウントで特定のアクション(権限の編集など)を実行させる可能性があります。(CVE-2020-10804)

- phpMyAdminの4.9.5以前の4.x、5.0.2以前の5.xで、libraries/classes/Controllers/Table/TableSearchController.php内の検索アクション用の特定のクエリを生成する際に、特定のパラメーターが適切にエスケープされないSQLインジェクションの脆弱性が発見されました。攻撃者が、細工されたデータベース名またはテーブル名を生成する可能性があります。ユーザーが悪意のあるデータベースまたはテーブルで特定の検索操作を試みる場合、攻撃が実行される可能性があります。(CVE-2020-10802)

- phpMyAdminの4.9.5以前の4.x、5.0.2以前の5.xで、SQLインジェクションの脆弱性が発見されました。悪意のあるコードを使用して、結果を取得して表示することでXSS攻撃をトリガーできます(tbl_get_field.phpおよびlibraries/classes/Display/Results.php)。攻撃者は細工されたデータを特定のデータベーステーブルに挿入できる必要があります。そのデータを取得すると(「Browse」タブなどを使用して)XSS攻撃のトリガーとなる可能性があります。(CVE-2020-10803)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdmin 4.9.5/5.0.2 以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2020-2/

https://www.phpmyadmin.net/security/PMASA-2020-3/

https://www.phpmyadmin.net/security/PMASA-2020-4/

プラグインの詳細

深刻度: High

ID: 144646

ファイル名: phpmyadmin_pmasa_5_0_2.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/30

更新日: 2021/1/4

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2020-10802

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6

Temporal Score: 4.4

ベクトル: AV:N/AC:M/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/3/21

脆弱性公開日: 2020/3/20

参照情報

CVE: CVE-2020-10802, CVE-2020-10803, CVE-2020-10804

CWE: 661