phpMyAdmin 4.9.0 < 4.9.6 / 5.0.0 < 5.0.3複数の脆弱性(PMASA-2020-5、PMASA-2020-6)

critical Nessus プラグイン ID 144649
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPアプリケーションをホストしています。

説明

自己報告されたバージョンによると、リモートのWebサーバーでホストされているphpMyAdminアプリケーションは、4.9.6より前の4.9.xもしくは5.0.3より前の5.0.xです。したがって、複数の脆弱性の影響を受けます。

-4.9.6以前のphpMyAdmin、5.0.3以前の5.xにより、XSSは細工されたリンクを介して変換機能を使用できます。(CVE-2020-26934)

- 4.9.6以前のphpMyAdmin、5.0.3以前の5.xのSearchControllerで問題が見つかりました。phpMyAdminが検索機能でSQLステートメントを処理する方法に、SQLインジェクションの脆弱性が発見されました。
攻撃者がこの欠陥を利用して、悪意のあるSQLをクエリに注入する可能性があります。(CVE-2020-26935)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

phpMyAdmin 4.9.6/5.0.3 以降にアップグレードしてください。

関連情報

https://www.phpmyadmin.net/security/PMASA-2020-5/

https://www.phpmyadmin.net/security/PMASA-2020-6/

プラグインの詳細

深刻度: Critical

ID: 144649

ファイル名: phpmyadmin_pmasa_5_0_3.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2020/12/31

更新日: 2021/1/4

依存関係: phpMyAdmin_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2020-26935

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:phpmyadmin:phpmyadmin

必要な KB アイテム: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/10/10

脆弱性公開日: 2020/10/10

参照情報

CVE: CVE-2020-26934, CVE-2020-26935

CWE: 661