SUSE SLES12セキュリティ更新プログラム:java-1_7_1-ibm(SUSE-SU-2021:0019-1)

medium Nessus プラグイン ID 144732

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

java-1_7_1-ibm用のこの更新プログラムでは、以下の問題が修正されています:

Java 7.1 Service Refresh 4 Fix Pack 75に更新してください[bsc#1180063、bsc#1177943] CVE-2020-14792 CVE-2020-14797 CVE-2020-14782 CVE-2020-14781 CVE-2020-14779 CVE-2020-14798 CVE-2020-14796 CVE-2020-14803

- クラスライブラリ:

- Z/OS固有のC関数であるsend_fileは、ファイルポインターの位置を変更します

- セキュリティ:

- 新しいoracle署名者証明書を追加します

- 証明書解析エラー

- JVMPメモリの増加は、IBMPKCS11IMPL暗号プロバイダーによって引き起こされる可能性があります

- websphere署名済みjarのチェックを削除します

sessionid.hashcodeにより生成される衝突が多すぎます

- Java 8 IBM certpathプロバイダーが、CLR接続タイムアウトに対するユーザー指定のシステムプロパティを遵守しません

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE OpenStack Cloud Crowbar 9:

zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2021-19=1

SUSE OpenStack Cloud Crowbar 8:

zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2021-19=1

SUSE OpenStack Cloud 9:

zypper in -t patch SUSE-OpenStack-Cloud-9-2021-19=1

SUSE OpenStack Cloud 8:

zypper in -t patch SUSE-OpenStack-Cloud-8-2021-19=1

SUSE OpenStack Cloud 7:

zypper in -t patch SUSE-OpenStack-Cloud-7-2021-19=1

SUSE Linux Enterprise Software Development Kit 12-SP5:

zypper in -t patch SUSE-SLE-SDK-12-SP5-2021-19=1

SUSE Linux Enterprise Server for SAP 12-SP4:

zypper in -t patch SUSE-SLE-SAP-12-SP4-2021-19=1

SUSE Linux Enterprise Server for SAP 12-SP3:

zypper in -t patch SUSE-SLE-SAP-12-SP3-2021-19=1

SUSE Linux Enterprise Server for SAP 12-SP2:

zypper in -t patch SUSE-SLE-SAP-12-SP2-2021-19=1

SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2021-19=1

SUSE Linux Enterprise Server 12-SP4-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2021-19=1

SUSE Linux Enterprise Server 12-SP3-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2021-19=1

SUSE Linux Enterprise Server 12-SP3-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2021-19=1

SUSE Linux Enterprise Server 12-SP2-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2021-19=1

SUSE Linux Enterprise Server 12-SP2-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2021-19=1

SUSE Enterprise Storage 5:

zypper in -t patch SUSE-Storage-5-2021-19=1

HPE Helion Openstack 8:

zypper in -t patch HPE-Helion-OpenStack-8-2021-19=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1177943

https://bugzilla.suse.com/show_bug.cgi?id=1180063

https://www.suse.com/security/cve/CVE-2020-14779/

https://www.suse.com/security/cve/CVE-2020-14781/

https://www.suse.com/security/cve/CVE-2020-14782/

https://www.suse.com/security/cve/CVE-2020-14792/

https://www.suse.com/security/cve/CVE-2020-14796/

https://www.suse.com/security/cve/CVE-2020-14797/

https://www.suse.com/security/cve/CVE-2020-14798/

https://www.suse.com/security/cve/CVE-2020-14803/

http://www.nessus.org/u?b2c2a8f8

プラグインの詳細

深刻度: Medium

ID: 144732

ファイル名: suse_SU-2021-0019-1.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2021/1/5

更新日: 2022/5/11

サポートされているセンサー: Nessus Agent

リスク情報

CVSS スコアのソース: CVE-2020-14792

VPR

リスクファクター: Low

スコア: 3.3

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:java-1_7_1-ibm, p-cpe:/a:novell:suse_linux:java-1_7_1-ibm-alsa, p-cpe:/a:novell:suse_linux:java-1_7_1-ibm-devel, p-cpe:/a:novell:suse_linux:java-1_7_1-ibm-jdbc, p-cpe:/a:novell:suse_linux:java-1_7_1-ibm-plugin, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/1/4

脆弱性公開日: 2020/10/21

参照情報

CVE: CVE-2020-14779, CVE-2020-14781, CVE-2020-14782, CVE-2020-14792, CVE-2020-14796, CVE-2020-14797, CVE-2020-14798, CVE-2020-14803