IBM HTTP Server 7.0.0.0 < 7.0.0.45 / 8.0.0.0 < 8.0.0.14 / 8.5.0.0 < 8.5.5.12 / 9.0.0.0 < 9.0.0.5の複数の脆弱性(563615)

critical Nessus プラグイン ID 144778
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

リモートホストで実行されているバージョンのIBM HTTP Serverは、Apache HTTP Serverに関連する以下のような複数の脆弱性の影響を受けます。

- 2.2.33より前の2.2.xおよび2.4.26より前の2.4.xのApache httpdでは、悪意のあるContent-Typeの応答ヘッダーを送信するとき、mod_mimeがバッファの末尾を1バイト超えて読み取る可能性があります。(CVE-2017-7679)

-Apache httpd 2.2.32および2.4.24で追加されたHTTPの厳格な解析の変更により、トークンリスト解析にバグが導入されました。これにより、ap_find_token()が入力文字列の終端を超えて検索する可能性があります。攻撃者が、リクエストヘッダーのシーケンスを巧妙に作りこむことで、セグメンテーション違反を引き起こしたり、ap_find_token()に正しくない値を返させる可能性があります。(CVE-2017-7668)

- 2.2.33より前の2.2.xと2.4.26より前の2.4.xのApache httpdでは、認証フェーズ以外でサードパーティモジュールがap_get_basic_auth_pw()を使用すると、認証要件がバイパスされる可能性があります。(CVE-2017-3167)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

IBM HTTP Serverのバージョン7.0.0.45、8.0.0.14、8.5.5.12、9.0.0.5以降にアップグレードしてください。または、暫定修正に必要な最低限のFix Packにアップグレードしてから、暫定修正PI82481を適用してください。

関連情報

https://www.ibm.com/support/pages/node/563615

プラグインの詳細

深刻度: Critical

ID: 144778

ファイル名: ibm_http_server_563615.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

ファミリー: Web Servers

公開日: 2021/1/6

更新日: 2021/1/25

依存関係: ibm_http_server_nix_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2017-7679

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:ibm:http_server

必要な KB アイテム: installed_sw/IBM HTTP Server (IHS)

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/7/19

脆弱性公開日: 2017/6/19

参照情報

CVE: CVE-2017-3167, CVE-2017-7668, CVE-2017-7679

BID: 99135, 99137, 99170